
<!DOCTYPE html>
<html lang="ur" dir="rtl" class="no-js">
<head>
<link href="/Content/responsive/VOA/ur/VOA-ur.css?&amp;av=0.1.0.0&amp;cb=161" rel="stylesheet"/>
<script src="//tags.tiqcdn.com/utag/bbg/voa-pangea/prod/utag.sync.js"></script> <script type='text/javascript' src='https://www.youtube.com/iframe_api'></script>
<script type="text/javascript">
//a general 'js' detection, must be on top level in <head>, due to CSS performance
document.documentElement.className = "js";
var cacheBuster = "161";
var appBaseUrl = "/";
var imgEnhancerBreakpoints = [0, 144, 256, 408, 650, 1023, 1597];
var isLoggingEnabled = true;
var isPreviewPage = false;
var isLivePreviewPage = false;
var pwaEnabled = false;
var swCacheDisabled;
</script>
<meta charset="utf-8" />
<title>ٹی ٹوئنٹی ورلڈکپ: سری لنکا کے ہسارانگا ہیٹ ٹرک کرنے والے کھلاڑیوں کی فہرست میں شامل</title>
<meta name="title" content="ٹی ٹوئنٹی ورلڈکپ: سری لنکا کے ہسارانگا ہیٹ ٹرک کرنے والے کھلاڑیوں کی فہرست میں شامل" />
<meta name="description" content="اس سنگ میل کے باوجود سری لنکا کو جنوبی افریقہ کے ہاتھوں چار وکٹ سے شکست ہوئی۔ البتہ جہاں سری لنکن شائقین اس میچ کو بھلانے کی کوشش کریں گے۔ وہیں ہسارانگا کو یہ میچ ہمیشہ یاد رہے گا۔" />
<meta name="keywords" content="خبریں, کھیل, ٹی ٹوئنٹی ورلڈ کپ 2021, sri lanka, icc, t20, World Cup" />
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<meta http-equiv="X-UA-Compatible" content="IE=edge" />
<meta property="fb:pages" content="106667936045610" />
<meta name="msvalidate.01" content="3286EE554B6F672A6F2E608C02343C0E" />
<link href="https://www.urduvoa.com/a/hasaranga-becomes-3rd-bowler-to-pick-a-hattrick-in-t20wc-30oct2021/6292086.html" rel="canonical" />
<meta name="apple-mobile-web-app-title" content="VOA" />
<meta name="apple-mobile-web-app-status-bar-style" content="black" />
<meta name="apple-itunes-app" content="app-id=632618796, app-argument=//6292086.rtl" />
<meta content="ٹی ٹوئنٹی ورلڈکپ: سری لنکا کے ہسارانگا ہیٹ ٹرک کرنے والے کھلاڑیوں کی فہرست میں شامل" property="og:title" />
<meta content="اس سنگ میل کے باوجود سری لنکا کو جنوبی افریقہ کے ہاتھوں چار وکٹ سے شکست ہوئی۔ البتہ جہاں سری لنکن شائقین اس میچ کو بھلانے کی کوشش کریں گے۔ وہیں ہسارانگا کو یہ میچ ہمیشہ یاد رہے گا۔" property="og:description" />
<meta content="article" property="og:type" />
<meta content="https://www.urduvoa.com/a/hasaranga-becomes-3rd-bowler-to-pick-a-hattrick-in-t20wc-30oct2021/6292086.html" property="og:url" />
<meta content="وی او اے" property="og:site_name" />
<meta content="https://www.facebook.com/voaurdu" property="article:publisher" />
<meta content="https://gdb.voanews.com/BEA733D4-B49B-4191-A0B3-46849EF53639_cx0_cy3_cw0_w1200_r1.jpg" property="og:image" />
<meta content="1200" property="og:image:width" />
<meta content="675" property="og:image:height" />
<meta content="1644719242209515" property="fb:app_id" />
<meta content="عمیر علوی" name="Author" />
<meta content="summary_large_image" name="twitter:card" />
<meta content="@SomeAccount" name="twitter:site" />
<meta content="https://gdb.voanews.com/BEA733D4-B49B-4191-A0B3-46849EF53639_cx0_cy3_cw0_w1200_r1.jpg" name="twitter:image" />
<link rel="amphtml" href="https://www.urduvoa.com/amp/hasaranga-becomes-3rd-bowler-to-pick-a-hattrick-in-t20wc-30oct2021/6292086.html" />
<script type="application/ld+json">{"articleSection":"کھیل","headline":"ٹی ٹوئنٹی ورلڈکپ: سری لنکا کے ہسارانگا ہیٹ ٹرک کرنے والے کھلاڑیوں کی فہرست میں شامل","inLanguage":"ur","keywords":"خبریں, کھیل, ٹی ٹوئنٹی ورلڈ کپ 2021, sri lanka, icc, t20, World Cup","author":{"@type":"Person","url":"","description":"","image":{"@type":"ImageObject"},"name":"عمیر علوی"},"datePublished":"2021-10-30","dateModified":"2021-10-30 16:37:41Z","publisher":{"logo":{"width":512,"height":220,"@type":"ImageObject","url":"https://www.urduvoa.com/Content/responsive/VOA/ur/img/logo.png"},"@type":"NewsMediaOrganization","url":"https://www.urduvoa.com","sameAs":["https://facebook.com/voaurdu","https://twitter.com/urduvoa","https://www.youtube.com/c/urduvoaservice","https://www.instagram.com/urduvoa/"],"name":"ٹی ٹوئنٹی ورلڈکپ: سری لنکا کے ہسارانگا ہیٹ ٹرک کرنے والے کھلاڑیوں کی فہرست میں شامل","alternateName":""},"@context":"https://schema.org","@type":"NewsArticle","mainEntityOfPage":"https://www.urduvoa.com/a/hasaranga-becomes-3rd-bowler-to-pick-a-hattrick-in-t20wc-30oct2021/6292086.html","url":"https://www.urduvoa.com/a/hasaranga-becomes-3rd-bowler-to-pick-a-hattrick-in-t20wc-30oct2021/6292086.html","description":"اس سنگ میل کے باوجود سری لنکا کو جنوبی افریقہ کے ہاتھوں چار وکٹ سے شکست ہوئی۔ البتہ جہاں سری لنکن شائقین اس میچ کو بھلانے کی کوشش کریں گے۔ وہیں ہسارانگا کو یہ میچ ہمیشہ یاد رہے گا۔","image":{"width":1080,"height":608,"@type":"ImageObject","url":"https://gdb.voanews.com/BEA733D4-B49B-4191-A0B3-46849EF53639_cx0_cy3_cw0_w1080_h608.jpg"},"name":"ٹی ٹوئنٹی ورلڈکپ: سری لنکا کے ہسارانگا ہیٹ ٹرک کرنے والے کھلاڑیوں کی فہرست میں شامل"}</script>
<script src="/Scripts/responsive/infographics.b?v=dVbZ-Cza7s4UoO3BqYSZdbxQZVF4BOLP5EfYDs4kqEo1&amp;av=0.1.0.0&amp;cb=161"></script>
<script src="/Scripts/responsive/loader.b?v=0n9qr4Q--Tl-jeZDMwtgde7i74L-1jyVwcOtkMlCDSw1&amp;av=0.1.0.0&amp;cb=161"></script>
<link rel="shortcut icon" href="/Content/responsive/VOA/img/webApp/favicon.ico" />
<link rel="apple-touch-icon" sizes="152x152" href="/Content/responsive/VOA/img/webApp/ico-152x152.png" />
<link rel="apple-touch-icon" sizes="144x144" href="/Content/responsive/VOA/img/webApp/ico-144x144.png" />
<link rel="apple-touch-icon" sizes="114x114" href="/Content/responsive/VOA/img/webApp/ico-114x114.png" />
<link rel="apple-touch-icon" sizes="72x72" href="/Content/responsive/VOA/img/webApp/ico-72x72.png" />
<link rel="apple-touch-icon-precomposed" href="/Content/responsive/VOA/img/webApp/ico-57x57.png" />
<link rel="icon" sizes="192x192" href="/Content/responsive/VOA/img/webApp/ico-192x192.png" />
<link rel="icon" sizes="128x128" href="/Content/responsive/VOA/img/webApp/ico-128x128.png" />
<meta name="msapplication-TileColor" content="#ffffff" />
<meta name="msapplication-TileImage" content="/Content/responsive/VOA/img/webApp/ico-144x144.png" />
<link rel="alternate" type="application/rss+xml" title="VOA - Top Stories [RSS]" href="/api/" />
<link rel="sitemap" type="application/rss+xml" href="/sitemap.xml" />
</head>
<body class=" nav-no-loaded can-ff pg-article print-lay-article nojs-images ">
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-N8MP7P" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript> <script type="text/javascript">
if (top.location === self.location) { //if not inside of an IFrame
var renderGtm = "true";
if (renderGtm === "true") {
(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-N8MP7P');
}
}
</script>
<!--Analytics tag js version start-->
<script type="text/javascript">
var utag_data={entity:"VOA",language:"Urdu",language_service:"VOA Urdu",short_language_service:"URD",property_id:"490",platform:"Responsive",platform_short:"R",runs_js:"Yes",page_title:"ٹی ٹوئنٹی ورلڈکپ: سری لنکا کے ہسارانگا ہیٹ ٹرک کرنے والے کھلاڑیوں کی فہرست میں شامل",page_type:"article",page_name:"ٹی ٹوئنٹی ورلڈکپ: سری لنکا کے ہسارانگا ہیٹ ٹرک کرنے والے کھلاڑیوں کی فہرست میں شامل",short_headline:"ٹی ٹوئنٹی ورلڈکپ: سری لنکا کے ہسارانگا ہ...",long_headline:"ٹی ٹوئنٹی ورلڈکپ: سری لنکا کے ہسارانگا ہیٹ ٹرک کرنے والے کھلاڑیوں کی فہرست میں شامل",headline:"ٹی ٹوئنٹی ورلڈکپ: سری لنکا کے ہسارانگا ہیٹ ٹرک کرنے والے کھلاڑیوں کی فہرست میں شامل",content_type:"article",subcontent_type:"article",enviro_type:"prod",url:"https://www.urduvoa.com/a/hasaranga-becomes-3rd-bowler-to-pick-a-hattrick-in-t20wc-30oct2021/6292086.html",domain:"www.urduvoa.com",pub_year:"2021",pub_month:"10",pub_day:"30",pub_hour:"16",pub_minute:"30",pub_weekday:"Saturday",dateline:"کراچی",byline:"علوی, عمیر",categories:"news,sports,t20-world-cup-2021",tags:"sri lanka;icc;t20;world cup",slug:"hasaranga-becomes-3rd-bowler-to-pick-a-hattrick-in-t20wc-30oct2021",section:"کھیل",english_section:"sports",article_uid:"6292086"};
if(typeof(TealiumTagFrom)==='function' && typeof(TealiumTagSearchKeyword)==='function') {
var utag_from=TealiumTagFrom();var utag_searchKeyword=TealiumTagSearchKeyword();
if(utag_searchKeyword!=null && utag_searchKeyword!=='' && utag_data["search_keyword"]==null) utag_data["search_keyword"]=utag_searchKeyword;if(utag_from!=null && utag_from!=='') utag_data["from"]=TealiumTagFrom();}
(function(a,b,c,d){ a="https://tags.tiqcdn.com/utag/bbg/voa-pangea/prod/utag.js"; b=document;c="script";d=b.createElement(c);d.src=a;d.type="text/java"+c;d.async=true; a=b.getElementsByTagName(c)[0];a.parentNode.insertBefore(d,a); })();
</script>
<!--Analytics tag js version end-->
<!-- Analytics tag management NoScript -->
<noscript>
<img style="position: absolute; border: none;" src="https://bbg.d1.sc.omtrdc.net/b/ss/bbgrvoaurdu-bbgprod-bbgentityvoa-bbgunitvoaurdu/1/G.4--NS/1251581710?pageName=voa%3aurd%3ar%3aarticle%3a%d9%b9%db%8c%20%d9%b9%d9%88%d8%a6%d9%86%d9%b9%db%8c%20%d9%88%d8%b1%d9%84%da%88%da%a9%d9%be%3a%20%d8%b3%d8%b1%db%8c%20%d9%84%d9%86%da%a9%d8%a7%20%da%a9%db%92%20%db%81%d8%b3%d8%a7%d8%b1%d8%a7%d9%86%da%af%d8%a7%20%db%81%db%8c%d9%b9%20%d9%b9%d8%b1%da%a9%20%da%a9%d8%b1%d9%86%db%92%20%d9%88%d8%a7%d9%84%db%92%20%da%a9%da%be%d9%84%d8%a7%da%91%db%8c%d9%88%da%ba%20%da%a9%db%8c%20%d9%81%db%81%d8%b1%d8%b3%d8%aa%20%d9%85%db%8c%da%ba%20%d8%b4%d8%a7%d9%85%d9%84&amp;c6=%d9%b9%db%8c%20%d9%b9%d9%88%d8%a6%d9%86%d9%b9%db%8c%20%d9%88%d8%b1%d9%84%da%88%da%a9%d9%be%3a%20%d8%b3%d8%b1%db%8c%20%d9%84%d9%86%da%a9%d8%a7%20%da%a9%db%92%20%db%81%d8%b3%d8%a7%d8%b1%d8%a7%d9%86%da%af%d8%a7%20%db%81%db%8c%d9%b9%20%d9%b9%d8%b1%da%a9%20%da%a9%d8%b1%d9%86%db%92%20%d9%88%d8%a7%d9%84%db%92%20%da%a9%da%be%d9%84%d8%a7%da%91%db%8c%d9%88%da%ba%20%da%a9%db%8c%20%d9%81%db%81%d8%b1%d8%b3%d8%aa%20%d9%85%db%8c%da%ba%20%d8%b4%d8%a7%d9%85%d9%84&amp;v6=D=c6&amp;g=https%3a%2f%2fwww.urduvoa.com&amp;c1=D=g&amp;v1=D=g&amp;events=event1&amp;c7=%d9%b9%db%8c%20%d9%b9%d9%88%d8%a6%d9%86%d9%b9%db%8c%20%d9%88%d8%b1%d9%84%da%88%da%a9%d9%be%3a%20%d8%b3%d8%b1%db%8c%20%d9%84%d9%86%da%a9%d8%a7%20%da%a9%db%92%20%db%81%d8%b3%d8%a7%d8%b1%d8%a7%d9%86%da%af%d8%a7%20%db%81%db%8c%d9%b9%20%d9%b9%d8%b1%da%a9%20%da%a9%d8%b1%d9%86%db%92%20%d9%88%d8%a7%d9%84%db%92%20%da%a9%da%be%d9%84%d8%a7%da%91%db%8c%d9%88%da%ba%20%da%a9%db%8c%20%d9%81%db%81%d8%b1%d8%b3%d8%aa%20%d9%85%db%8c%da%ba%20%d8%b4%d8%a7%d9%85%d9%84&amp;v7=D=c7&amp;c16=voa%20urdu&amp;v16=D=c16&amp;c5=sports&amp;v5=D=c5&amp;ch=urdu&amp;v15=D=ch&amp;c15=D=ch&amp;c4=article&amp;v4=D=c4&amp;c14=6292086&amp;v14=D=c14&amp;c20=no&amp;c17=responsive&amp;v17=D=c17" alt="analytics" width="1" height="1" /></noscript>
<!-- End of Analytics tag management NoScript -->
<!--*** Accessibility links - For ScreenReaders only ***-->
<section>
<div class="sr-only">
<h2>رسائی کے لنکس</h2>
<ul>
<li><a href="#content" data-disable-smooth-scroll="1">مرکزی مواد پر جائیں</a></li>
<li><a href="#navigation" data-disable-smooth-scroll="1">مرکزی نیویگیشن پر جائیں</a></li>
<li><a href="#txtHeaderSearch" data-disable-smooth-scroll="1">تلاش پر جائیں</a></li>
</ul>
</div>
</section>
<div dir="rtl">
<div id="page">
<aside>
<div class="c-lightbox overlay-modal">
<div class="c-lightbox__intro">
<h2 class="c-lightbox__intro-title"></h2>
<button class="btn btn--rounded c-lightbox__btn c-lightbox__intro-next" title="اگلا صفحہ">
<span class="ico ico--rounded ico-chevron-forward"></span>
<span class="sr-only">اگلا صفحہ</span>
</button>
</div>
<div class="c-lightbox__nav">
<button class="btn btn--rounded c-lightbox__btn c-lightbox__btn--close" title="بند کیجئے">
<span class="ico ico--rounded ico-close"></span>
<span class="sr-only">بند کیجئے</span>
</button>
<button class="btn btn--rounded c-lightbox__btn c-lightbox__btn--prev" title="پچھلا صفحہ">
<span class="ico ico--rounded ico-chevron-backward"></span>
<span class="sr-only">پچھلا صفحہ</span>
</button>
<button class="btn btn--rounded c-lightbox__btn c-lightbox__btn--next" title="اگلا صفحہ">
<span class="ico ico--rounded ico-chevron-forward"></span>
<span class="sr-only">اگلا صفحہ</span>
</button>
</div>
<div class="c-lightbox__content-wrap">
<figure class="c-lightbox__content">
<span class="c-spinner c-spinner--lightbox">
<img src="/Content/responsive/img/player-spinner.png"
alt="please wait"
title="please wait" />
</span>
<div class="c-lightbox__img">
<div class="thumb">
<img src="" alt="" />
</div>
</div>
<figcaption>
<div class="c-lightbox__info c-lightbox__info--foot">
<span class="c-lightbox__counter"></span>
<span class="caption c-lightbox__caption"></span>
</div>
</figcaption>
</figure>
</div>
</div>
<div class="print-dialogue">
<div class="container">
<h3 class="print-dialogue__title section-head">Print Options:</h3>
<div class="print-dialogue__opts">
<ul class="print-dialogue__opt-group">
<li class="form__group form__group--checkbox">
<input class="form__check " id="checkboxImages" name="checkboxImages" type="checkbox" checked="checked" />
<label for="checkboxImages" class="form__label m-t-md">Images</label>
</li>
<li class="form__group form__group--checkbox">
<input class="form__check " id="checkboxMultimedia" name="checkboxMultimedia" type="checkbox" checked="checked" />
<label for="checkboxMultimedia" class="form__label m-t-md">Multimedia</label>
</li>
</ul>
<ul class="print-dialogue__opt-group">
<li class="form__group form__group--checkbox">
<input class="form__check " id="checkboxEmbedded" name="checkboxEmbedded" type="checkbox" checked="checked" />
<label for="checkboxEmbedded" class="form__label m-t-md">Embedded Content</label>
</li>
<li class="form__group form__group--checkbox">
<input class="form__check " id="checkboxComments" name="checkboxComments" type="checkbox" />
<label for="checkboxComments" class="form__label m-t-md">Comments</label>
</li>
</ul>
</div>
<div class="print-dialogue__buttons">
<button class="btn btn--secondary close-button" type="button" title="منسوخ کیجئے">
<span class="btn__text ">منسوخ کیجئے</span>
</button>
<button class="btn btn-cust-print m-l-sm" type="button" title="Print">
<span class="btn__text ">Print</span>
</button>
</div>
</div>
</div>
<div class="ctc-message pos-fix">
<div class="ctc-message__inner">Link has been copied to clipboard</div>
</div>
</aside>
<div class="hdr">
<div class="hdr-nav-frag">
<div class="container">
<a href="/" class="fl" id="logo">
<img src="/Content/responsive/VOA/ur/img/logo.png" alt="logo" />
</a>
<img src="/Content/responsive/VOA/ur/img/logo-print_color.png" class="logo-print logo-print--color" alt="logo-print">
<ul class="compact-actions">
<li class="action action-entity-sites">
<a href="/navigation/allsites">
<span class="ico ico-languages"></span>
</a>
</li>
<li class="action action-srch">
<a href="/s">
<span class="ico ico-search"></span>
<span class="arrow-open"></span>
</a>
</li>
<li class="action action-menu">
<a href="/navigation.html" class="link-js">
<span class="ico ico-menu"></span>
<span class="arrow-open"></span>
</a>
</li>
</ul>
<div class="actions">
<div class="actions__safe-wrap">
<div class="action action-entity-sites">
<a href="/navigation/allsites" class="action__link" data-smoothscroll="disabled">
<span class="ico ico-languages"></span> <span class="action__txt action__txt--entity-sites">زبان</span>
<span class="arrow-open"></span>
</a>
</div>
<div class="action action-login"></div>
<div class="action action--editions">
<a class="action__link" href="https://learningenglish.voanews.com/">
<span class="action__txt " title="Learning English">Learning English</span>
</a>
</div>
<div class="action action-socials socials">
<ul class="follow">
<li>
<a href="https://facebook.com/voaurdu" title="ہم فیس بک پر موجود ہیں" data-analytics-text="follow_on_facebook" class="btn btn--rounded js-social-btn btn-facebook" target="_blank">
<span class="ico ico-facebook-alt ico--nobg"></span>
</a>
</li>
<li>
<a href="https://twitter.com/urduvoa" title="ہم ٹوئٹر پر موجود ہیں" data-analytics-text="follow_on_twitter" class="btn btn--rounded js-social-btn btn-twitter" target="_blank">
<span class="ico ico-twitter ico--nobg"></span>
</a>
</li>
<li>
<a href="https://www.youtube.com/c/urduvoaservice" title="ہم یوٹیوب پر موجود ہیں" data-analytics-text="follow_on_youtube" class="btn btn--rounded js-social-btn btn-youtube" target="_blank">
<span class="ico ico-youtube ico--nobg"></span>
</a>
</li>
<li>
<a href="https://www.instagram.com/urduvoa/" title="Follow us on Instagram" data-analytics-text="follow_on_instagram" class="btn btn--rounded js-social-btn btn-instagram" target="_blank">
<span class="ico ico-instagram ico--nobg"></span>
</a>
</li>
</ul>
</div>
</div>
<div class="action pnl-srch-top collapsed">
<form action="/s" id="form-headerSearch" method="get" pp="" r="" role="search" tab=""><div class="srch-elem">
<ul class="form__list">
<li class="form__group m-tb-0">
<span class="input-wrap">
<label for="txtHeaderSearch" class="form__label sr-only">تلاش کیجئے</label>
<input type="text" id="txtHeaderSearch" name="k" placeholder="search text ..." accesskey="s" value="" class="form__input analyticstag-event" onkeydown="if (event.keyCode === 13) { FireAnalyticsTagEventOnSearch('search', $dom.get('txtHeaderSearch')[0].value) }" />
</span>
<button title="تلاش کیجئے" type="submit" class="btn btn-srch analyticstag-event" onclick="FireAnalyticsTagEventOnSearch('search', $dom.get('txtHeaderSearch')[0].value) ">
<span class="ico ico-search"></span>
<span class="text">تلاش کیجئے</span>
</button>
</li>
</ul>
</div></form>
</div>
</div>
</div>
</div>
<div class="sticky-nav-wrap container">
<div class="sticked-nav-actions">
<a href="#" title="search" class="btn btn--rounded btn-open-srch">
<span class="ico ico-search"></span>
</a>
</div>
</div>
<div class="nav-hdr-outer-container">
<div class="container" id="nav-hdr-container">
<div class="navigation collapsed" id="navigation">
<div class="media">
<ul class="items">
<li class="collapsible item collapsed has-box" id="menu-item-listen">
<a class="handler" href="/Navigation/LiveAudioNJS" title="وی او اے اردو پوڈ کاسٹ" tabindex="0">
<span class="ico ico-audio-rounded"></span>
<span class="text">وی او اے اردو پوڈ کاسٹ</span>
<span class="live"></span>
<span class="ico ico-chevron-up"></span><span class="ico ico-chevron-down"></span><span class="ico ico-plus"></span><span class="ico ico-minus"></span>
</a>
<div class="inner">
</div>
</li>
<li class="collapsible collapsed item has-box" id="menu-item-watch">
<a class="handler" href="/Navigation/LiveVideoNJS" title="ویو 360" tabindex="1">
<span class="ico ico-play-rounded"></span>
<span class="text">ویو 360</span>
<span class="ico ico-chevron-up"></span><span class="ico ico-chevron-down"></span><span class="ico ico-plus"></span><span class="ico ico-minus"></span>
</a>
<div class="inner">
</div>
</li>
</ul>
</div>
<div class="menu">
<ul class="items">
<li class=" item">
<a class="handler" href="/p/3637.html" title="صفحہ اول">صفحہ اول</a>
</li>
<li class=" item">
<a class="handler" href="/p/7254.html" title="ٹی ٹوئنٹی ورلڈ کپ 2021">ٹی ٹوئنٹی ورلڈ کپ 2021</a>
</li>
<li class=" item">
<a class="handler" href="/p/7266.html" title="کرونا وائرس">کرونا وائرس</a>
</li>
<li class=" item">
<a class="handler" href="/p/5950.html" title="پاکستان">پاکستان</a>
</li>
<li class=" item">
<a class="handler" href="/p/7722.html" title="افغانستان">افغانستان</a>
</li>
<li class=" item">
<a class="handler" href="/p/5951.html" title="امریکہ">امریکہ</a>
</li>
<li class=" item">
<a class="handler" href="/p/7144.html" title="دُنیا">دُنیا</a>
</li>
<li class=" item">
<a class="handler" href="/p/5954.html" title="کھیل">کھیل</a>
</li>
<li class=" item">
<a class="handler" href="/p/5953.html" title="آرٹ">آرٹ</a>
</li>
<li class=" item">
<a class="handler" href="/p/7384.html" title="سائنس و ٹیکنالوجی">سائنس و ٹیکنالوجی</a>
</li>
<li class=" last-menu-item item">
<a class="handler" href="https://editorials.voa.gov/z/6214" title="اداریہ">اداریہ</a>
</li>
<li class="item login logged-out" id="menu-item-login-01">
<a href="/login.html" class="handler">
<span class="ico ico-user"></span>
<span class="label">Login / Register</span>
</a>
</li>
<li class="service item collapsible collapsed show-more">
<span class="handler" id="service-handler">
<span class="more">مزید</span><span class="ico ico-menu"></span>
</span>
<div class="inner">
<ul class="stored-items subitems"></ul>
<ul class="options subitems">
<li class="edition subitem ">
<a href="https://learningenglish.voanews.com/" title="Learning English" class="handler">
Learning English </a>
</li>
</ul>
</div>
</li>
</ul>
</div>
<div class="menu-box media-nav" id="menu-item-watch-box">
<div class="container">
<ul class="items">
<li class="item" id="tube-0">
<div class="inner">
<ul>
<li class="media-block-wrap hlight">
<h3 class="section-head">تازہ ترین شو</h3>
</li>
</ul>
</div>
</li>
<li class="media-block-wrap custom-links">
<h3 class="section-head">مکمل شوز</h3>
<ul class="subitems">
<li class="subitem">
<a class="handler" href="/z/5178">ویو 360</a>
</li>
</ul>
</li>
</ul>
</div>
</div>
<div class="menu-box media-nav" id="menu-item-listen-box">
<div class="container">
<ul class="items">
<li class="item" id="tube-58">
<div class="inner">
<ul>
<li class="media-block-wrap hlight">
<a class="tube-name" href="/Navigation/LiveAudio/#tube-58">Urdu</a>
<h3 class="section-head">تازہ ترین پروگرام</h3>
</li>
</ul>
</div>
</li>
<li class="media-block-wrap custom-links">
<h3 class="section-head">آڈیو مینیو</h3>
<ul class="subitems">
<li class="subitem">
<a class="handler" href="/z/6798">نیوز بلیٹن</a>
</li>
<li class="subitem">
<a class="handler" href="/z/6799">نیوز رپورٹس</a>
</li>
<li class="subitem">
<a class="handler" href="/z/6797">ویکلی ہائی لائٹس</a>
</li>
<li class="subitem">
<a class="handler" href="https://urduvoa.com/z/6379">خالد حمید کی یادیں</a>
</li>
<li class="subitem">
<a class="handler" href="https://urduvoa.com/z/6013">بیپر</a>
</li>
<li class="subitem">
<a class="handler" href="/z/6800">آڈیو اسٹوریز</a>
</li>
</ul>
</li>
</ul>
</div>
</div>
</div>
</div>
</div>
<div data-trigger="btn-open-srch" class="sticked-nav-popup popup-srch">
<div class="container">
<div class="stick-srch-form">
<form action="/s" id="form-stickyNavSearch" method="get" pp="" r="" role="search" tab=""><div class="srch-elem">
<ul class="form__list">
<li class="form__group m-tb-0">
<span class="input-wrap">
<label for="txtStickyNavSearch" class="form__label sr-only">تلاش کیجئے</label>
<input type="text" id="txtStickyNavSearch" name="k" placeholder="search text ..." accesskey="s" value="" class="form__input analyticstag-event" onkeydown="if (event.keyCode === 13) { FireAnalyticsTagEventOnSearch('search', $dom.get('txtStickyNavSearch')[0].value) }" />
</span>
<button title="تلاش کیجئے" type="submit" class="btn btn-srch analyticstag-event" onclick="FireAnalyticsTagEventOnSearch('search', $dom.get('txtStickyNavSearch')[0].value) ">
<span class="ico ico-search"></span>
<span class="text">تلاش کیجئے</span>
</button>
</li>
</ul>
</div></form>
<button class="btn btn-close"><span class="ico ico-close"></span></button>
</div>
</div>
</div>
<div data-trigger="btn-open-sharing-more" class="sticked-nav-popup popup-share">
<div class="container">
<button class="btn btn-close"><span class="ico ico-close"></span></button>
</div>
</div>
</div>
<div class="c-hlights c-hlights--breaking c-hlights--no-item js-hidden" data-hlight-display="mobile,desktop">
<div class="c-hlights__wrap container p-0">
<div class="c-hlights__nav">
<a role="button" href="#" title="پچھلا صفحہ">
<span class="ico ico-chevron-backward m-0"></span>
<span class="sr-only">پچھلا صفحہ</span>
</a>
<a role="button" href="#" title="اگلا صفحہ">
<span class="ico ico-chevron-forward m-0"></span>
<span class="sr-only">اگلا صفحہ</span>
</a>
</div>
<input class="switcher-controller" id="more-less-1" type="checkbox">
<span class="c-hlights__label">
<span class="">بریکنگ نیوز</span>
<span class="switcher-trigger">
<label for="more-less-1" class="switcher-trigger__label switcher-trigger__label--more p-b-0" title="مزید">
<span class="ico ico-chevron-down"></span>
</label>
<label for="more-less-1" class="switcher-trigger__label switcher-trigger__label--less p-b-0" title="Show less">
<span class="ico ico-chevron-up"></span>
</label>
</span>
</span>
<ul class="c-hlights__items switcher-target">
</ul>
</div>
</div>
<div class="c-hlights c-hlights--live hidden-sm hidden-md hidden-lg c-hlights--no-item js-hidden" data-hlight-display="mobile">
<div class="c-hlights__wrap container p-0">
<div class="c-hlights__nav">
<a role="button" href="#" title="پچھلا صفحہ">
<span class="ico ico-chevron-backward m-0"></span>
<span class="sr-only">پچھلا صفحہ</span>
</a>
<a role="button" href="#" title="اگلا صفحہ">
<span class="ico ico-chevron-forward m-0"></span>
<span class="sr-only">اگلا صفحہ</span>
</a>
</div>
<input class="switcher-controller" id="more-less-2" type="checkbox">
<span class="c-hlights__label">
<span class="badge badge--live">Live</span>
<span class="switcher-trigger">
<label for="more-less-2" class="switcher-trigger__label switcher-trigger__label--more p-b-0" title="مزید">
<span class="ico ico-chevron-down"></span>
</label>
<label for="more-less-2" class="switcher-trigger__label switcher-trigger__label--less p-b-0" title="Show less">
<span class="ico ico-chevron-up"></span>
</label>
</span>
</span>
<ul class="c-hlights__items switcher-target">
</ul>
</div>
</div> <div id="content">
<div class="container">
<div class="hdr-container">
<div class="row">
<div class="col-category col-xs-12 col-md-2 pull-left"> <img src="" data-src="https://livetracker.voa.pangea-cms.com/counter.lt?PageType=1&amp;RecordId=6292086&amp;SiteId=445&amp;r=1371069318&amp;it=0&amp;pd=20211030163041" alt="" style="display: none; position: absolute; top: 0; left: 0" class="live-tracker-image"
data-lt-referrerControllerUrl="https://livetracker.voa.pangea-cms.com/api/lt/ref" data-lt-itemType="Content" data-lt-recordId="6292086" data-lt-siteId="445" />
<noscript>
<img src="https://livetracker.voa.pangea-cms.com/counter.lt?PageType=1&amp;RecordId=6292086&amp;SiteId=445&amp;r=1371069318&amp;it=0&amp;pd=20211030163041" alt="" style="display: none; position: absolute; top: 0; left: 0" class="live-tracker-image"
data-lt-referrerControllerUrl="https://livetracker.voa.pangea-cms.com/api/lt/ref" data-lt-itemType="Content" data-lt-recordId="6292086" data-lt-siteId="445" />
</noscript>
<div class="category">
<a class="" href="/z/2272">کھیل</a> </div>
</div><div class="col-title col-xs-12 col-md-10 pull-right"> <h1 class="title pg-title" >
ٹی ٹوئنٹی ورلڈکپ: سری لنکا کے ہسارانگا ہیٹ ٹرک کرنے والے کھلاڑیوں کی فہرست میں شامل
</h1>
</div><div class="col-publishing-details col-xs-12 col-sm-12 col-md-2 pull-left"> <div class="publishing-details">
<div class="published">
<span class="date" >
<time datetime="2021-10-30T21:30:00+05:00">
آخری بار اپڈیٹ کیا گیا 1 hour ago
</time>
</span>
</div>
<div class="links">
<ul class="links__list links__list--column">
<li class="links__item">
<a class="links__item-link" href="/author/عمیر-علوی/-j_yr" title="عمیر علوی">عمیر علوی</a>
</li>
</ul>
</div>
</div>
</div><div class="col-lg-12 separator"> <div class="separator">
<hr class="title-line" />
</div>
</div><div class="col-multimedia col-xs-12 col-md-10 pull-right"> <div class="cover-media">
<figure class="media-image js-media-expand">
<div class="img-wrap">
<div class="thumb thumb16_9">
<img src="https://gdb.voanews.com/BEA733D4-B49B-4191-A0B3-46849EF53639_cx0_cy3_cw0_w250_r1_s.jpg" itemprop="url" alt="اس سنگ میل کے باوجود سری لنکا کو جنوبی افریقہ کے ہاتھوں چار وکٹ سے شکست ہوئی۔ البتہ جہاں سری لنکن شائقین اس میچ کو بھلانے کی کوشش کریں گے۔ وہیں ہسارانگا کو یہ میچ ہمیشہ یاد رہے گا۔" />
</div>
<span class="ico ico-fullscreen ico--media-expand ico--rounded"></span>
</div>
<figcaption>
<span class="caption" itemprop="caption" data-cms-inline-wrap="caption" data-cms-inline-text="">اس سنگ میل کے باوجود سری لنکا کو جنوبی افریقہ کے ہاتھوں چار وکٹ سے شکست ہوئی۔ البتہ جہاں سری لنکن شائقین اس میچ کو بھلانے کی کوشش کریں گے۔ وہیں ہسارانگا کو یہ میچ ہمیشہ یاد رہے گا۔</span>
</figcaption>
</figure>
</div>
</div><div class="col-xs-12 col-md-2 pull-left article-share pos-rel"> <div class="share--box">
<aside class="share flex-column js-share--apply-sticky js-share--expandable js-share--horizontal"
>
<span class="label label--share"></span>
<ul class="share__list">
<li class="share__item">
<a href="https://facebook.com/sharer.php?u=https%3a%2f%2fwww.urduvoa.com%2fa%2fhasaranga-becomes-3rd-bowler-to-pick-a-hattrick-in-t20wc-30oct2021%2f6292086.html"
data-analytics-text="share_on_facebook"
title="فیس بک پر شیئر کیجئیے" target="_blank"
class="btn btn--rounded btn-facebook js-social-btn">
<span class="ico ico--rounded ico-facebook ico--l">
</span>
</a>
<span class="share__count share__count--facebook share__count--empty">&nbsp;</span>
</li>
<li class="share__item">
<a href="https://twitter.com/share?url=https%3a%2f%2fwww.urduvoa.com%2fa%2fhasaranga-becomes-3rd-bowler-to-pick-a-hattrick-in-t20wc-30oct2021%2f6292086.html&amp;text=%d9%b9%db%8c+%d9%b9%d9%88%d8%a6%d9%86%d9%b9%db%8c+%d9%88%d8%b1%d9%84%da%88%da%a9%d9%be%3a+%d8%b3%d8%b1%db%8c+%d9%84%d9%86%da%a9%d8%a7+%da%a9%db%92+%db%81%d8%b3%d8%a7%d8%b1%d8%a7%d9%86%da%af%d8%a7+%db%81%db%8c%d9%b9+%d9%b9%d8%b1%da%a9+%da%a9%d8%b1%d9%86%db%92+%d9%88%d8%a7%d9%84%db%92+%da%a9%da%be%d9%84%d8%a7%da%91%db%8c%d9%88%da%ba+%da%a9%db%8c+%d9%81%db%81%d8%b1%d8%b3%d8%aa+%d9%85%db%8c%da%ba+%d8%b4%d8%a7%d9%85%d9%84"
data-analytics-text="share_on_twitter"
title="ٹوئٹر پر شیئر کیجئیے" target="_blank"
class="btn btn--rounded btn-twitter js-social-btn">
<span class="ico ico--rounded ico-twitter ico--l">
</span>
</a>
<span class="share__count shares__twitter share__count--empty">&nbsp;</span>
</li>
<li class="share__item">
<div class="ctc">
<input type="text" class="ctc__input" readonly="readonly">
<button class="btn btn--rounded btn--ctc ctc__button" value="text" role="copy link" js-href="https://www.urduvoa.com/a/hasaranga-becomes-3rd-bowler-to-pick-a-hattrick-in-t20wc-30oct2021/6292086.html" title="copy link">
<span class="ico ico-content-copy ico--rounded ico--l"></span>
</button>
</div>
</li>
<li class="share__item">
<a href="mailto:?body=https%3a%2f%2fwww.urduvoa.com%2fa%2fhasaranga-becomes-3rd-bowler-to-pick-a-hattrick-in-t20wc-30oct2021%2f6292086.html&amp;subject=ٹی ٹوئنٹی ورلڈکپ: سری لنکا کے ہسارانگا ہیٹ ٹرک کرنے والے کھلاڑیوں کی فہرست میں شامل"
title="اپنے دوست کو ای میل کریں"
class="btn btn--rounded btn-email ">
<span class="ico ico--rounded ico-email ico--l">
</span>
</a>
<span class="share__count share__count--email share__count--empty">&nbsp;</span>
</li>
<li class="share__item share__item--sharing-more">
<a title="مزید اشتراک کرنے کےلیے" class="btn btn--rounded btn--show-more hidden">
<span class="ico ico--rounded ico-ellipsis ico--l"></span>
</a>
</li>
</ul>
</aside>
<div class="sticky-share-container" style="display:none">
<div class="container">
<a href="https://www.urduvoa.com" id="logo-sticky-share">&nbsp;</a>
<div class="pg-title pg-title--sticky-share">
ٹی ٹوئنٹی ورلڈکپ: سری لنکا کے ہسارانگا ہیٹ ٹرک کرنے والے کھلاڑیوں کی فہرست میں شامل
</div>
<div class="sticked-nav-actions">
<aside class="share share--sticky js-share--expandable">
<span class="label label--share">share</span>
<ul class="share__list">
<li class="share__item share__item--horizontal">
<a href="https://facebook.com/sharer.php?u=https%3a%2f%2fwww.urduvoa.com%2fa%2fhasaranga-becomes-3rd-bowler-to-pick-a-hattrick-in-t20wc-30oct2021%2f6292086.html"
data-analytics-text="share_on_facebook"
title="فیس بک پر شیئر کیجئیے" target="_blank"
class="btn btn--rounded btn-facebook js-social-btn">
<span class="ico ico--rounded ico-facebook ico--s">
</span>
</a>
</li>
<li class="share__item share__item--horizontal">
<a href="https://twitter.com/share?url=https%3a%2f%2fwww.urduvoa.com%2fa%2fhasaranga-becomes-3rd-bowler-to-pick-a-hattrick-in-t20wc-30oct2021%2f6292086.html&amp;text=%d9%b9%db%8c+%d9%b9%d9%88%d8%a6%d9%86%d9%b9%db%8c+%d9%88%d8%b1%d9%84%da%88%da%a9%d9%be%3a+%d8%b3%d8%b1%db%8c+%d9%84%d9%86%da%a9%d8%a7+%da%a9%db%92+%db%81%d8%b3%d8%a7%d8%b1%d8%a7%d9%86%da%af%d8%a7+%db%81%db%8c%d9%b9+%d9%b9%d8%b1%da%a9+%da%a9%d8%b1%d9%86%db%92+%d9%88%d8%a7%d9%84%db%92+%da%a9%da%be%d9%84%d8%a7%da%91%db%8c%d9%88%da%ba+%da%a9%db%8c+%d9%81%db%81%d8%b1%d8%b3%d8%aa+%d9%85%db%8c%da%ba+%d8%b4%d8%a7%d9%85%d9%84"
data-analytics-text="share_on_twitter"
title="ٹوئٹر پر شیئر کیجئیے" target="_blank"
class="btn btn--rounded btn-twitter js-social-btn">
<span class="ico ico--rounded ico-twitter ico--s">
</span>
</a>
</li>
<li class="share__item share__item--additional share__item--horizontal">
<div class="ctc">
<input type="text" class="ctc__input" readonly="readonly">
<button class="btn btn--rounded btn--ctc ctc__button" value="text" role="copy link" js-href="https://www.urduvoa.com/a/hasaranga-becomes-3rd-bowler-to-pick-a-hattrick-in-t20wc-30oct2021/6292086.html" title="copy link">
<span class="ico ico-content-copy ico--rounded ico--s"></span>
</button>
</div>
</li>
<li class="share__item share__item--additional share__item--horizontal">
<a href="mailto:?body=https%3a%2f%2fwww.urduvoa.com%2fa%2fhasaranga-becomes-3rd-bowler-to-pick-a-hattrick-in-t20wc-30oct2021%2f6292086.html&amp;subject=ٹی ٹوئنٹی ورلڈکپ: سری لنکا کے ہسارانگا ہیٹ ٹرک کرنے والے کھلاڑیوں کی فہرست میں شامل"
title="اپنے دوست کو ای میل کریں"
class="btn btn--rounded btn-email ">
<span class="ico ico--rounded ico-email ico--s">
</span>
</a>
</li>
<li class="share__item share__item--sharing-more">
<a title="مزید اشتراک کرنے کےلیے" class="btn btn--rounded btn--show-more hidden">
<span class="ico ico--rounded ico-ellipsis ico--s"></span>
</a>
</li>
</ul>
</aside>
</div>
</div>
</div>
<div class="links">
<p class="buttons link-comments p-0">
<a href="#comments" class="btn btn--link p-t-0">
<span class="ico ico-comment"></span><span class="btn__text">تبصرے دیکھیں</span>
</a>
</p>
<p class="link-print visible-md visible-lg buttons p-0">
<button class="btn btn--link btn-print p-t-0" onclick="if (typeof FireAnalyticsTagEvent === 'function') {FireAnalyticsTagEvent({ on_page_event: 'print_story' });}return false" title="(CTRL+P)">
<span class="ico ico-print"></span>
<span class="btn__text">Print</span>
</button>
</p>
</div>
</div>
</div>
</div>
</div>
<div class="body-container">
<div class="row">
<div class="col-xs-12 col-sm-12 col-md-10 col-lg-10 pull-right">
<div class="row">
<div class="col-xs-12 col-sm-12 col-md-8 col-lg-8 pull-left bottom-offset content-offset">
<div id="article-content" class="content-floated-wrap fb-quotable">
<div class="wsw">
<span class="dateline">کراچی —&nbsp;</span>
<p><strong>سری لنکا کے لیگ اسپنر ونیندو ہسارانگا کی ہیٹ ٹرک، جنوبی افریقہ کے خلاف ٹیم کو شکست سے تو نہ بچا سکی، البتہ اس کارنامے کے بعد وہ ان کھلاڑیوں کی فہرست میں شامل ہو گئے ہیں جنہوں نے میگا ایونٹ میں مسلسل تین یا اس سے زیادہ گیندوں پر وکٹیں حاصل کی۔</strong><br />
<br />
اس سنگ میل کے باوجود سری لنکا کو جنوبی افریقہ کے ہاتھوں چار وکٹ سے شکست ہوئی۔ البتہ جہاں سری لنکن شائقین اس میچ کو بھلانے کی کوشش کریں گے۔ وہیں ہسارانگا کو یہ میچ ہمیشہ یاد رہے گا۔</p><div class="clear"></div>
<div class="wsw__embed">
<div class="infgraphicsAttach" >
<script type="text/javascript">
initInfographics(
{
groups:[],
params:[{"Name":"embed_html","Value":"\u0026lt;blockquote class=\"twitter-tweet\"\u0026gt;\u0026lt;p lang=\"en\" dir=\"ltr\"\u0026gt;Miller delivers for South Africa 💪\u0026lt;a href=\"https://twitter.com/hashtag/T20WorldCup?src=hash\u0026amp;ref_src=twsrc%5Etfw\"\u0026gt;#T20WorldCup\u0026lt;/a\u0026gt; | \u0026lt;a href=\"https://twitter.com/hashtag/SAvSL?src=hash\u0026amp;ref_src=twsrc%5Etfw\"\u0026gt;#SAvSL\u0026lt;/a\u0026gt; | \u0026lt;a href=\"https://t.co/bJIWWFNtds\"\u0026gt;https://t.co/bJIWWFNtds\u0026lt;/a\u0026gt; \u0026lt;a href=\"https://t.co/DGCKu9gskW\"\u0026gt;pic.twitter.com/DGCKu9gskW\u0026lt;/a\u0026gt;\u0026lt;/p\u0026gt;— T20 World Cup (@T20WorldCup) \u0026lt;a href=\"https://twitter.com/T20WorldCup/status/1454443310672539653?ref_src=twsrc%5Etfw\"\u0026gt;October 30, 2021\u0026lt;/a\u0026gt;\u0026lt;/blockquote\u0026gt;||data-pangea-embed::\"true\"","DefaultValue":"","HtmlEncode":false,"Type":"HTML"}],
isMobile:true
});
</script>
<div class="snippetLoading twitterSnippet"></div>
<script type="text/javascript">
(function (d) {
var userInput = Infographics.Param["embed_html"],
thisSnippet = (d.getElementsByClassName ? d.getElementsByClassName("twitterSnippet") : d.querySelectorAll(".twitterSnippet"))[0],
render = function () {
var madeDiv, bquote, sId = "twitterAPIForSnippet";
try {
madeDiv = document.createElement("div");
madeDiv.innerHTML = userInput;
} catch (e) {
thisSnippet.innerHTML = "Twitter Embed Code is invalid or incomplete.";
return;
}
bquote = madeDiv.childNodes[0];
if (bquote.tagName.toLowerCase() === "blockquote" && bquote.className.indexOf("twitter") !== -1) { //remove everything except paragraphs and links
var all = bquote.getElementsByTagName("*");
for (var i = all.length - 1; i >= 0; i--) {
var elm = all[i];
var tag = elm.tagName.toLowerCase();
if (tag !== "a" && tag !== "p")
all[i].parentNode.removeChild(all[i]);
}
} else {
thisSnippet.innerHTML = "Twitter Embed Code does not contain proper Twitter blockquote.";
return;
}
if (!window.twttr && !d.getElementById(sId)) { //async request Twitter API
var js, firstJs = d.getElementsByTagName("script")[0];
js = d.createElement("script");
js.id = sId;
js.src = "//platform.twitter.com/widgets.js";
firstJs.parentNode.insertBefore(js, firstJs);
}
thisSnippet.parentNode.style.width = "100%";
thisSnippet.appendChild(bquote);
if (window.twttr && window.twttr.widgets) {
window.twttr.widgets.load();
window.twttr.events.bind("rendered", function (e) {
//fix twitter bug rendering multiple embeds per tweet. Can be deleted after Twitter fix the issue
if (e.target) {
var par = e.target.parentElement;
if (par && par.className === "twitterSnippetProcessed" &&
e.target.previousSibling && e.target.previousSibling.nodeName.toLowerCase() === "iframe") {
//this is duplicate embed, delete it
par.removeChild(e.target);
}
}
});
}
};
thisSnippet.className = "twitterSnippetProcessed";
if (d.readyState === "uninitialized" || d.readyState === "loading")
window.addEventListener("load", render);
else //liveblog, ajax
render();
})(document);
</script>
</div>
</div>
<p>ہسارانگا کی ہیٹ ٹرک اس لیے بھی قابل ذکر ہے کیوں کہ ان کے تین میں سے دو شکار مستند بلے باز تھے۔</p>
<p>سب سے پہلے انہوں نے 15ویں اوور کی آخری گیند پر ایڈن مارکرم کو بولڈ کر کے جنوبی افریقی ٹیم کو مشکلات میں ڈالا، جو 19 رنز پر سیٹ نظر آرہے تھے۔</p><div class="clear"></div>
<div class="wsw__embed">
<div class="infgraphicsAttach" >
<script type="text/javascript">
initInfographics(
{
groups:[],
params:[{"Name":"embed_html","Value":"\u0026lt;blockquote class=\"twitter-tweet\"\u0026gt;\u0026lt;p lang=\"en\" dir=\"ltr\"\u0026gt;Hat-trick for Hasaranga 🔥 Pretorius departs for a 🦆\u0026lt;a href=\"https://twitter.com/hashtag/T20WorldCup?src=hash\u0026amp;ref_src=twsrc%5Etfw\"\u0026gt;#T20WorldCup\u0026lt;/a\u0026gt; | \u0026lt;a href=\"https://twitter.com/hashtag/SAvSL?src=hash\u0026amp;ref_src=twsrc%5Etfw\"\u0026gt;#SAvSL\u0026lt;/a\u0026gt; | \u0026lt;a href=\"https://t.co/bJIWWFNtds\"\u0026gt;https://t.co/bJIWWFNtds\u0026lt;/a\u0026gt; \u0026lt;a href=\"https://t.co/du7Ck86DvD\"\u0026gt;pic.twitter.com/du7Ck86DvD\u0026lt;/a\u0026gt;\u0026lt;/p\u0026gt;— T20 World Cup (@T20WorldCup) \u0026lt;a href=\"https://twitter.com/T20WorldCup/status/1454438120166809605?ref_src=twsrc%5Etfw\"\u0026gt;October 30, 2021\u0026lt;/a\u0026gt;\u0026lt;/blockquote\u0026gt;||data-pangea-embed::\"true\"","DefaultValue":"","HtmlEncode":false,"Type":"HTML"}],
isMobile:true
});
</script>
<div class="snippetLoading twitterSnippet"></div>
<script type="text/javascript">
(function (d) {
var userInput = Infographics.Param["embed_html"],
thisSnippet = (d.getElementsByClassName ? d.getElementsByClassName("twitterSnippet") : d.querySelectorAll(".twitterSnippet"))[0],
render = function () {
var madeDiv, bquote, sId = "twitterAPIForSnippet";
try {
madeDiv = document.createElement("div");
madeDiv.innerHTML = userInput;
} catch (e) {
thisSnippet.innerHTML = "Twitter Embed Code is invalid or incomplete.";
return;
}
bquote = madeDiv.childNodes[0];
if (bquote.tagName.toLowerCase() === "blockquote" && bquote.className.indexOf("twitter") !== -1) { //remove everything except paragraphs and links
var all = bquote.getElementsByTagName("*");
for (var i = all.length - 1; i >= 0; i--) {
var elm = all[i];
var tag = elm.tagName.toLowerCase();
if (tag !== "a" && tag !== "p")
all[i].parentNode.removeChild(all[i]);
}
} else {
thisSnippet.innerHTML = "Twitter Embed Code does not contain proper Twitter blockquote.";
return;
}
if (!window.twttr && !d.getElementById(sId)) { //async request Twitter API
var js, firstJs = d.getElementsByTagName("script")[0];
js = d.createElement("script");
js.id = sId;
js.src = "//platform.twitter.com/widgets.js";
firstJs.parentNode.insertBefore(js, firstJs);
}
thisSnippet.parentNode.style.width = "100%";
thisSnippet.appendChild(bquote);
if (window.twttr && window.twttr.widgets) {
window.twttr.widgets.load();
window.twttr.events.bind("rendered", function (e) {
//fix twitter bug rendering multiple embeds per tweet. Can be deleted after Twitter fix the issue
if (e.target) {
var par = e.target.parentElement;
if (par && par.className === "twitterSnippetProcessed" &&
e.target.previousSibling && e.target.previousSibling.nodeName.toLowerCase() === "iframe") {
//this is duplicate embed, delete it
par.removeChild(e.target);
}
}
});
}
};
thisSnippet.className = "twitterSnippetProcessed";
if (d.readyState === "uninitialized" || d.readyState === "loading")
window.addEventListener("load", render);
else //liveblog, ajax
render();
})(document);
</script>
</div>
</div>
<p>اس کے بعد اپنے اگلے اوور کی پہلی دو گیندوں پر بھی ہسارانگا نے تباہی مچائی۔</p>
<p>ان کا پہلا شکار جنوبی افریقہ کے کپتان ٹیمبا باووما تھے جو 46 رنز بناکر باؤنڈری پر کیچ ہوئے۔ تو دوسرے ڈوین پریٹوریس تھے۔ جو لانگ آن پر چھکا مارنے کی کوشش میں کیچ آؤٹ ہوئے۔</p>
<h3 class="wsw__h3" style="color:Red;"><strong>ٹی ٹوئنٹی ورلڈکپ میں دوسری ہیٹ ٹرک</strong></h3>
<p>سری لنکا کے ونیندو ہسارانگا نہ تو اس ٹی ٹوئنٹی ورلڈکپ میں ہیٹ ٹرک کرنے والے پہلے کھلاڑی ہیں۔ نہ ہی اس ایڈیشن میں یہ کارنامہ انجام دینے والے پہلے بالر۔</p>
<p>ٹی ٹوئنٹی ورلڈکپ کی پہلی ہیٹ ٹرک کا سہرا آسٹریلوی فاسٹ بالر بریٹ لی کے سر جاتا ہے جنہوں نے پہلے ٹی ٹوئنٹی ورلڈکپ میں بنگلہ دیش کے خلاف یہ سنگ میل عبور کیا تھا۔</p><div class="clear"></div>
<div class="wsw__embed">
<div class="infgraphicsAttach" >
<script type="text/javascript">
initInfographics(
{
groups:[],
params:[{"Name":"embed_html","Value":"\u0026lt;blockquote class=\"twitter-tweet\"\u0026gt;\u0026lt;p lang=\"en\" dir=\"ltr\"\u0026gt;☝️ Shakib Al Hasan☝️ Mashrafe Mortaza☝️ Alok KapaliOn this day in 2007, Brett Lee claims the first T20I hat-trick 🎩 \u0026lt;a href=\"https://t.co/uY87xCLsmM\"\u0026gt;pic.twitter.com/uY87xCLsmM\u0026lt;/a\u0026gt;\u0026lt;/p\u0026gt;— ICC (@ICC) \u0026lt;a href=\"https://twitter.com/ICC/status/1438300088720363522?ref_src=twsrc%5Etfw\"\u0026gt;September 16, 2021\u0026lt;/a\u0026gt;\u0026lt;/blockquote\u0026gt;||data-pangea-embed::\"true\"","DefaultValue":"","HtmlEncode":false,"Type":"HTML"}],
isMobile:true
});
</script>
<div class="snippetLoading twitterSnippet"></div>
<script type="text/javascript">
(function (d) {
var userInput = Infographics.Param["embed_html"],
thisSnippet = (d.getElementsByClassName ? d.getElementsByClassName("twitterSnippet") : d.querySelectorAll(".twitterSnippet"))[0],
render = function () {
var madeDiv, bquote, sId = "twitterAPIForSnippet";
try {
madeDiv = document.createElement("div");
madeDiv.innerHTML = userInput;
} catch (e) {
thisSnippet.innerHTML = "Twitter Embed Code is invalid or incomplete.";
return;
}
bquote = madeDiv.childNodes[0];
if (bquote.tagName.toLowerCase() === "blockquote" && bquote.className.indexOf("twitter") !== -1) { //remove everything except paragraphs and links
var all = bquote.getElementsByTagName("*");
for (var i = all.length - 1; i >= 0; i--) {
var elm = all[i];
var tag = elm.tagName.toLowerCase();
if (tag !== "a" && tag !== "p")
all[i].parentNode.removeChild(all[i]);
}
} else {
thisSnippet.innerHTML = "Twitter Embed Code does not contain proper Twitter blockquote.";
return;
}
if (!window.twttr && !d.getElementById(sId)) { //async request Twitter API
var js, firstJs = d.getElementsByTagName("script")[0];
js = d.createElement("script");
js.id = sId;
js.src = "//platform.twitter.com/widgets.js";
firstJs.parentNode.insertBefore(js, firstJs);
}
thisSnippet.parentNode.style.width = "100%";
thisSnippet.appendChild(bquote);
if (window.twttr && window.twttr.widgets) {
window.twttr.widgets.load();
window.twttr.events.bind("rendered", function (e) {
//fix twitter bug rendering multiple embeds per tweet. Can be deleted after Twitter fix the issue
if (e.target) {
var par = e.target.parentElement;
if (par && par.className === "twitterSnippetProcessed" &&
e.target.previousSibling && e.target.previousSibling.nodeName.toLowerCase() === "iframe") {
//this is duplicate embed, delete it
par.removeChild(e.target);
}
}
});
}
};
thisSnippet.className = "twitterSnippetProcessed";
if (d.readyState === "uninitialized" || d.readyState === "loading")
window.addEventListener("load", render);
else //liveblog, ajax
render();
})(document);
</script>
</div>
</div>
<p>انہوں نے کیپ ٹاؤن میں بنگلہ دیش کے شکیب الحسن، مشرفی مرتضیٰ اور الوک کپالی کو واپس پویلین بھیج کر ٹی ٹوئنٹی ورلڈکپ اور ٹی ٹوئنٹی انٹرنیشنل کی پہلی ہیٹ ٹرک کی تھی۔</p>
<p>اس کے بعد ٹی ٹوئنٹی کرکٹ میں تو کئی کھلاڑیوں نے یہ کارنامہ انجام دیا البتہ ورلڈکپ میں کسی بھی بالر کواس کامیابی کے لیے 14 سال انتظار کرنا پڑا۔</p>
<p>ورلڈکپ میں 14 برس بعد ہیٹ ٹرک کرنے کا اعزاز آئرلینڈ کے فاسٹ بالر کرٹس کیمفر کو جاتا ہے جنہوں نے ایک نہیں، دو نہیں بلکہ مسلسل چار گیندوں پر چار ڈچ کھلاڑیوں کو آؤٹ کیا تھا۔</p><div class="clear"></div>
<div class="wsw__embed">
<div class="infgraphicsAttach" >
<script type="text/javascript">
initInfographics(
{
groups:[],
params:[{"Name":"embed_html","Value":"\u0026lt;blockquote class=\"twitter-tweet\"\u0026gt;\u0026lt;p lang=\"en\" dir=\"ltr\"\u0026gt;Not to mention his double hat-trick 🥵Well played, Curtis Campher 👏\u0026lt;a href=\"https://twitter.com/hashtag/T20WorldCup?src=hash\u0026amp;ref_src=twsrc%5Etfw\"\u0026gt;#T20WorldCup\u0026lt;/a\u0026gt; \u0026lt;a href=\"https://t.co/yO3BlN8hlN\"\u0026gt;pic.twitter.com/yO3BlN8hlN\u0026lt;/a\u0026gt;\u0026lt;/p\u0026gt;— ICC (@ICC) \u0026lt;a href=\"https://twitter.com/ICC/status/1450251347505332224?ref_src=twsrc%5Etfw\"\u0026gt;October 19, 2021\u0026lt;/a\u0026gt;\u0026lt;/blockquote\u0026gt;||data-pangea-embed::\"true\"","DefaultValue":"","HtmlEncode":false,"Type":"HTML"}],
isMobile:true
});
</script>
<div class="snippetLoading twitterSnippet"></div>
<script type="text/javascript">
(function (d) {
var userInput = Infographics.Param["embed_html"],
thisSnippet = (d.getElementsByClassName ? d.getElementsByClassName("twitterSnippet") : d.querySelectorAll(".twitterSnippet"))[0],
render = function () {
var madeDiv, bquote, sId = "twitterAPIForSnippet";
try {
madeDiv = document.createElement("div");
madeDiv.innerHTML = userInput;
} catch (e) {
thisSnippet.innerHTML = "Twitter Embed Code is invalid or incomplete.";
return;
}
bquote = madeDiv.childNodes[0];
if (bquote.tagName.toLowerCase() === "blockquote" && bquote.className.indexOf("twitter") !== -1) { //remove everything except paragraphs and links
var all = bquote.getElementsByTagName("*");
for (var i = all.length - 1; i >= 0; i--) {
var elm = all[i];
var tag = elm.tagName.toLowerCase();
if (tag !== "a" && tag !== "p")
all[i].parentNode.removeChild(all[i]);
}
} else {
thisSnippet.innerHTML = "Twitter Embed Code does not contain proper Twitter blockquote.";
return;
}
if (!window.twttr && !d.getElementById(sId)) { //async request Twitter API
var js, firstJs = d.getElementsByTagName("script")[0];
js = d.createElement("script");
js.id = sId;
js.src = "//platform.twitter.com/widgets.js";
firstJs.parentNode.insertBefore(js, firstJs);
}
thisSnippet.parentNode.style.width = "100%";
thisSnippet.appendChild(bquote);
if (window.twttr && window.twttr.widgets) {
window.twttr.widgets.load();
window.twttr.events.bind("rendered", function (e) {
//fix twitter bug rendering multiple embeds per tweet. Can be deleted after Twitter fix the issue
if (e.target) {
var par = e.target.parentElement;
if (par && par.className === "twitterSnippetProcessed" &&
e.target.previousSibling && e.target.previousSibling.nodeName.toLowerCase() === "iframe") {
//this is duplicate embed, delete it
par.removeChild(e.target);
}
}
});
}
};
thisSnippet.className = "twitterSnippetProcessed";
if (d.readyState === "uninitialized" || d.readyState === "loading")
window.addEventListener("load", render);
else //liveblog, ajax
render();
})(document);
</script>
</div>
</div>
<p>انہوں نے یہ کارنامہ ٹی ٹوئنٹی ورلڈکپ کے تیسرے میچ میں ابوظہبی کے مقام پر انجام دیا۔ کیمفر نے میچ کا دسواں اوور پھینکا جس میں چار مرتبہ انہیں کامیابی حاصل ہوئی۔</p>
<p>ان کے اوور کی دوسری گیند پر کالن ایکرمین، تیسری پر رائن ٹین ڈوشے ، چوتھی پر اسکاٹ ایڈورڈز اور پانچویں پر ریولوف وین ڈر میرو آؤٹ ہو کر پویلین واپس گئے۔</p>
<p>پچاس اوورز کے کرکٹ ورلڈکپ میں کئی کھلاڑی یہ کارنامہ انجام دے چکے ہیں۔</p>
<p>ٹی ٹوئنٹی ورلڈکپ میں ہیٹ ٹرک کا کارنامہ تو صرف تین بالرز نے انجام دیا ہے۔ البتہ ون ڈے کرکٹ میں یہ ریکارڈ کئی کھلاڑیوں کے پاس ہے۔</p>
<p>صرف ون ڈے ورلڈکپ میں ہی اب تک 11 کھلاڑی تین گیندوں پر تین بلے بازوں کو آؤٹ کر چکے ہیں جس میں سے سری لنکا کے لسیتھ ملنگا دو بار ایسا کرکے سرفہرست ہیں۔</p>
<p>ویسے تو ورلڈکپ کرکٹ کا آغاز 1975 میں ہوا اور ون ڈے کی پہلی ہیٹ ٹرک 1982 میں پاکستان کے جلال الدین نے کی تھی۔ البتہ ورلڈکپ میں یہ کارنامہ سب سے پہلے بھارت کے چیتن شرما نے انجام دیا۔ یہ وہی چیتن شرما ہیں جن کی آخری گیند پر جاوید میانداد نے شارجہ کے مقام پر تاریخی چھکا مارا تھا۔</p><div class="clear"></div>
<div class="wsw__embed">
<div class="infgraphicsAttach" >
<script type="text/javascript">
initInfographics(
{
groups:[],
params:[{"Name":"embed_html","Value":"\u0026lt;blockquote class=\"twitter-tweet\"\u0026gt;\u0026lt;p lang=\"en\" dir=\"ltr\"\u0026gt;While we all have been swooning over the \u0026lt;a href=\"https://twitter.com/hashtag/Hattrick?src=hash\u0026amp;ref_src=twsrc%5Etfw\"\u0026gt;#Hattrick\u0026lt;/a\u0026gt; scored by \u0026lt;a href=\"https://twitter.com/MdShami11?ref_src=twsrc%5Etfw\"\u0026gt;@MdShami11\u0026lt;/a\u0026gt; against \u0026lt;a href=\"https://twitter.com/hashtag/Afghanistan?src=hash\u0026amp;ref_src=twsrc%5Etfw\"\u0026gt;#Afghanistan\u0026lt;/a\u0026gt; recently, I am reminded of Chetan Sharma, as he scored the first ever \u0026lt;a href=\"https://twitter.com/hashtag/WorldCup?src=hash\u0026amp;ref_src=twsrc%5Etfw\"\u0026gt;#WorldCup\u0026lt;/a\u0026gt; hat-trick in 1987 at \u0026lt;a href=\"https://twitter.com/hashtag/Nagpur?src=hash\u0026amp;ref_src=twsrc%5Etfw\"\u0026gt;#Nagpur\u0026lt;/a\u0026gt; against \u0026lt;a href=\"https://twitter.com/hashtag/NewZealand?src=hash\u0026amp;ref_src=twsrc%5Etfw\"\u0026gt;#NewZealand\u0026lt;/a\u0026gt;! \u0026lt;a href=\"https://twitter.com/BCCI?ref_src=twsrc%5Etfw\"\u0026gt;@BCCI\u0026lt;/a\u0026gt; \u0026lt;a href=\"https://twitter.com/ICC?ref_src=twsrc%5Etfw\"\u0026gt;@ICC\u0026lt;/a\u0026gt; \u0026lt;a href=\"https://twitter.com/cricketworldcup?ref_src=twsrc%5Etfw\"\u0026gt;@cricketworldcup\u0026lt;/a\u0026gt; \u0026lt;a href=\"https://twitter.com/chetans1987?ref_src=twsrc%5Etfw\"\u0026gt;@chetans1987\u0026lt;/a\u0026gt; \u0026lt;a href=\"https://twitter.com/BLACKCAPS?ref_src=twsrc%5Etfw\"\u0026gt;@BLACKCAPS\u0026lt;/a\u0026gt; \u0026lt;a href=\"https://t.co/PoqdjwDKse\"\u0026gt;pic.twitter.com/PoqdjwDKse\u0026lt;/a\u0026gt;\u0026lt;/p\u0026gt;— Dhanraj Nathwani (@DhanrajNathwani) \u0026lt;a href=\"https://twitter.com/DhanrajNathwani/status/1143158035721797632?ref_src=twsrc%5Etfw\"\u0026gt;June 24, 2019\u0026lt;/a\u0026gt;\u0026lt;/blockquote\u0026gt;||data-pangea-embed::\"true\"","DefaultValue":"","HtmlEncode":false,"Type":"HTML"}],
isMobile:true
});
</script>
<div class="snippetLoading twitterSnippet"></div>
<script type="text/javascript">
(function (d) {
var userInput = Infographics.Param["embed_html"],
thisSnippet = (d.getElementsByClassName ? d.getElementsByClassName("twitterSnippet") : d.querySelectorAll(".twitterSnippet"))[0],
render = function () {
var madeDiv, bquote, sId = "twitterAPIForSnippet";
try {
madeDiv = document.createElement("div");
madeDiv.innerHTML = userInput;
} catch (e) {
thisSnippet.innerHTML = "Twitter Embed Code is invalid or incomplete.";
return;
}
bquote = madeDiv.childNodes[0];
if (bquote.tagName.toLowerCase() === "blockquote" && bquote.className.indexOf("twitter") !== -1) { //remove everything except paragraphs and links
var all = bquote.getElementsByTagName("*");
for (var i = all.length - 1; i >= 0; i--) {
var elm = all[i];
var tag = elm.tagName.toLowerCase();
if (tag !== "a" && tag !== "p")
all[i].parentNode.removeChild(all[i]);
}
} else {
thisSnippet.innerHTML = "Twitter Embed Code does not contain proper Twitter blockquote.";
return;
}
if (!window.twttr && !d.getElementById(sId)) { //async request Twitter API
var js, firstJs = d.getElementsByTagName("script")[0];
js = d.createElement("script");
js.id = sId;
js.src = "//platform.twitter.com/widgets.js";
firstJs.parentNode.insertBefore(js, firstJs);
}
thisSnippet.parentNode.style.width = "100%";
thisSnippet.appendChild(bquote);
if (window.twttr && window.twttr.widgets) {
window.twttr.widgets.load();
window.twttr.events.bind("rendered", function (e) {
//fix twitter bug rendering multiple embeds per tweet. Can be deleted after Twitter fix the issue
if (e.target) {
var par = e.target.parentElement;
if (par && par.className === "twitterSnippetProcessed" &&
e.target.previousSibling && e.target.previousSibling.nodeName.toLowerCase() === "iframe") {
//this is duplicate embed, delete it
par.removeChild(e.target);
}
}
});
}
};
thisSnippet.className = "twitterSnippetProcessed";
if (d.readyState === "uninitialized" || d.readyState === "loading")
window.addEventListener("load", render);
else //liveblog, ajax
render();
})(document);
</script>
</div>
</div>
<p>ناگ پور کے مقام پر چیتن شرما نیوزی لینڈ کے تین بلے بازوں کین ردرفرڈ، این اسمتھ اور ایون چیٹ فیلڈ کو بولڈ کرکے ورلڈکپ میں ہیٹ ٹرک کرنے والے پہلے کھلاڑی بنے۔</p>
<p>اس کے 12 سال بعد پاکستان کے موجودہ عبوری ہیڈ کوچ ثقلین مشتاق بھی ورلڈکپ میں ہیٹ ٹرک کرنے میں کامیاب ہوئے۔</p>
<p>ثقلین مشتاق نے اوول کے میدان پر زمبابوے کے ہنری اولنگا، ایڈم ہکل اور پومی منگوا کو آؤٹ کیا تھا۔</p><div class="clear"></div>
<div class="wsw__embed">
<div class="infgraphicsAttach" >
<script type="text/javascript">
initInfographics(
{
groups:[],
params:[{"Name":"embed_html","Value":"\u0026lt;blockquote class=\"twitter-tweet\"\u0026gt;\u0026lt;p lang=\"en\" dir=\"ltr\"\u0026gt;☝️ Henry Olonga☝️ Adam Huckle☝️ Pommie Mbangwa\u0026lt;a href=\"https://twitter.com/hashtag/OnThisDay?src=hash\u0026amp;ref_src=twsrc%5Etfw\"\u0026gt;#OnThisDay\u0026lt;/a\u0026gt; in 1999, Saqlain Mushtaq became the second bowler to pick up a \u0026lt;a href=\"https://twitter.com/cricketworldcup?ref_src=twsrc%5Etfw\"\u0026gt;@cricketworldcup\u0026lt;/a\u0026gt; hat-trick 🤩 \u0026lt;a href=\"https://t.co/COfQoHJng5\"\u0026gt;pic.twitter.com/COfQoHJng5\u0026lt;/a\u0026gt;\u0026lt;/p\u0026gt;— ICC (@ICC) \u0026lt;a href=\"https://twitter.com/ICC/status/1270981773317615616?ref_src=twsrc%5Etfw\"\u0026gt;June 11, 2020\u0026lt;/a\u0026gt;\u0026lt;/blockquote\u0026gt;||data-pangea-embed::\"true\"","DefaultValue":"","HtmlEncode":false,"Type":"HTML"}],
isMobile:true
});
</script>
<div class="snippetLoading twitterSnippet"></div>
<script type="text/javascript">
(function (d) {
var userInput = Infographics.Param["embed_html"],
thisSnippet = (d.getElementsByClassName ? d.getElementsByClassName("twitterSnippet") : d.querySelectorAll(".twitterSnippet"))[0],
render = function () {
var madeDiv, bquote, sId = "twitterAPIForSnippet";
try {
madeDiv = document.createElement("div");
madeDiv.innerHTML = userInput;
} catch (e) {
thisSnippet.innerHTML = "Twitter Embed Code is invalid or incomplete.";
return;
}
bquote = madeDiv.childNodes[0];
if (bquote.tagName.toLowerCase() === "blockquote" && bquote.className.indexOf("twitter") !== -1) { //remove everything except paragraphs and links
var all = bquote.getElementsByTagName("*");
for (var i = all.length - 1; i >= 0; i--) {
var elm = all[i];
var tag = elm.tagName.toLowerCase();
if (tag !== "a" && tag !== "p")
all[i].parentNode.removeChild(all[i]);
}
} else {
thisSnippet.innerHTML = "Twitter Embed Code does not contain proper Twitter blockquote.";
return;
}
if (!window.twttr && !d.getElementById(sId)) { //async request Twitter API
var js, firstJs = d.getElementsByTagName("script")[0];
js = d.createElement("script");
js.id = sId;
js.src = "//platform.twitter.com/widgets.js";
firstJs.parentNode.insertBefore(js, firstJs);
}
thisSnippet.parentNode.style.width = "100%";
thisSnippet.appendChild(bquote);
if (window.twttr && window.twttr.widgets) {
window.twttr.widgets.load();
window.twttr.events.bind("rendered", function (e) {
//fix twitter bug rendering multiple embeds per tweet. Can be deleted after Twitter fix the issue
if (e.target) {
var par = e.target.parentElement;
if (par && par.className === "twitterSnippetProcessed" &&
e.target.previousSibling && e.target.previousSibling.nodeName.toLowerCase() === "iframe") {
//this is duplicate embed, delete it
par.removeChild(e.target);
}
}
});
}
};
thisSnippet.className = "twitterSnippetProcessed";
if (d.readyState === "uninitialized" || d.readyState === "loading")
window.addEventListener("load", render);
else //liveblog, ajax
render();
})(document);
</script>
</div>
</div>
<p>چار سال بعد سری لنکا کے چمندا واس نے جنوبی افریقہ میں کھیلے گئے ورلڈکپ کی پہلی ہیٹ ٹرل بنگلہ دیش کے خلاف کی۔</p>
<p>اسی ایڈیشن میں آسٹریلیا کے بریٹ لی نے کینیا کے تین کھلاڑیوں کو اتنی ہی گیندوں پر آؤٹ کرکے تاریخ رقم کی۔</p><div class="clear"></div>
<div class="wsw__embed">
<div class="infgraphicsAttach" >
<script type="text/javascript">
initInfographics(
{
groups:[],
params:[{"Name":"embed_html","Value":"\u0026lt;blockquote class=\"twitter-tweet\"\u0026gt;\u0026lt;p lang=\"en\" dir=\"ltr\"\u0026gt;🌟 World record ODI figures: 8️⃣ / 1️⃣ 9️⃣ 🌟 🇱🇰’s most successful Test fast bowler: 3️⃣ 5️⃣ 5️⃣ 🌟 🇱🇰’s most successful ODI fast bowler: 4️⃣ 0️⃣ 0️⃣ Birthday boy Chaminda Vaas also remains the only bowler to take a hat-trick with the first three balls of an international match 👇 \u0026lt;a href=\"https://t.co/OGxbOeJcAB\"\u0026gt;pic.twitter.com/OGxbOeJcAB\u0026lt;/a\u0026gt;\u0026lt;/p\u0026gt;— ICC (@ICC) \u0026lt;a href=\"https://twitter.com/ICC/status/1221674231345418241?ref_src=twsrc%5Etfw\"\u0026gt;January 27, 2020\u0026lt;/a\u0026gt;\u0026lt;/blockquote\u0026gt;||data-pangea-embed::\"true\"","DefaultValue":"","HtmlEncode":false,"Type":"HTML"}],
isMobile:true
});
</script>
<div class="snippetLoading twitterSnippet"></div>
<script type="text/javascript">
(function (d) {
var userInput = Infographics.Param["embed_html"],
thisSnippet = (d.getElementsByClassName ? d.getElementsByClassName("twitterSnippet") : d.querySelectorAll(".twitterSnippet"))[0],
render = function () {
var madeDiv, bquote, sId = "twitterAPIForSnippet";
try {
madeDiv = document.createElement("div");
madeDiv.innerHTML = userInput;
} catch (e) {
thisSnippet.innerHTML = "Twitter Embed Code is invalid or incomplete.";
return;
}
bquote = madeDiv.childNodes[0];
if (bquote.tagName.toLowerCase() === "blockquote" && bquote.className.indexOf("twitter") !== -1) { //remove everything except paragraphs and links
var all = bquote.getElementsByTagName("*");
for (var i = all.length - 1; i >= 0; i--) {
var elm = all[i];
var tag = elm.tagName.toLowerCase();
if (tag !== "a" && tag !== "p")
all[i].parentNode.removeChild(all[i]);
}
} else {
thisSnippet.innerHTML = "Twitter Embed Code does not contain proper Twitter blockquote.";
return;
}
if (!window.twttr && !d.getElementById(sId)) { //async request Twitter API
var js, firstJs = d.getElementsByTagName("script")[0];
js = d.createElement("script");
js.id = sId;
js.src = "//platform.twitter.com/widgets.js";
firstJs.parentNode.insertBefore(js, firstJs);
}
thisSnippet.parentNode.style.width = "100%";
thisSnippet.appendChild(bquote);
if (window.twttr && window.twttr.widgets) {
window.twttr.widgets.load();
window.twttr.events.bind("rendered", function (e) {
//fix twitter bug rendering multiple embeds per tweet. Can be deleted after Twitter fix the issue
if (e.target) {
var par = e.target.parentElement;
if (par && par.className === "twitterSnippetProcessed" &&
e.target.previousSibling && e.target.previousSibling.nodeName.toLowerCase() === "iframe") {
//this is duplicate embed, delete it
par.removeChild(e.target);
}
}
});
}
};
thisSnippet.className = "twitterSnippetProcessed";
if (d.readyState === "uninitialized" || d.readyState === "loading")
window.addEventListener("load", render);
else //liveblog, ajax
render();
})(document);
</script>
</div>
</div>
<p>لیکن سب سے لمبی اور کامیاب ہیٹ ٹرک کا کریڈٹ سری لنکا کے لسیتھ مالنگا کو جاتا ہے جن کے سائیڈ آن ایکشن کی وجہ سے بلے باز مشکلات کا شکار ہی رہتے تھے۔</p>
<p>گیانا کے میدان پر 2007 کے ورلڈکپ میں انہوں نے شان پولاک، اینڈریو ہال، جیک کیلس اور مخایا این ٹینی کو چار گیندوں پر آؤٹ کرکے دنیائے کرکٹ کی سب سے انوکھی ہیٹ ٹرک کی جس میں چار کھلاڑیوں کو اپنی وکٹ سے ہاتھ دھونا پڑا۔</p><div class="clear"></div>
<div class="wsw__embed">
<div class="infgraphicsAttach" >
<script type="text/javascript">
initInfographics(
{
groups:[],
params:[{"Name":"embed_html","Value":"\u0026lt;blockquote class=\"twitter-tweet\"\u0026gt;\u0026lt;p lang=\"en\" dir=\"ltr\"\u0026gt;It%27s something special when you take a hat-trick - even more so when you take four wickets in four balls like Lasith Malinga did in 2007!Has it got your backing to reach the next stage of \u0026lt;a href=\"https://twitter.com/bira91?ref_src=twsrc%5Etfw\"\u0026gt;@bira91\u0026lt;/a\u0026gt;%27s \u0026lt;a href=\"https://twitter.com/cricketworldcup?ref_src=twsrc%5Etfw\"\u0026gt;@cricketworldcup\u0026lt;/a\u0026gt; Greatest Moments? \u0026lt;a href=\"https://t.co/EgFHlri9sc\"\u0026gt;pic.twitter.com/EgFHlri9sc\u0026lt;/a\u0026gt;\u0026lt;/p\u0026gt;— ICC (@ICC) \u0026lt;a href=\"https://twitter.com/ICC/status/1114884754736861184?ref_src=twsrc%5Etfw\"\u0026gt;April 7, 2019\u0026lt;/a\u0026gt;\u0026lt;/blockquote\u0026gt;||data-pangea-embed::\"true\"","DefaultValue":"","HtmlEncode":false,"Type":"HTML"}],
isMobile:true
});
</script>
<div class="snippetLoading twitterSnippet"></div>
<script type="text/javascript">
(function (d) {
var userInput = Infographics.Param["embed_html"],
thisSnippet = (d.getElementsByClassName ? d.getElementsByClassName("twitterSnippet") : d.querySelectorAll(".twitterSnippet"))[0],
render = function () {
var madeDiv, bquote, sId = "twitterAPIForSnippet";
try {
madeDiv = document.createElement("div");
madeDiv.innerHTML = userInput;
} catch (e) {
thisSnippet.innerHTML = "Twitter Embed Code is invalid or incomplete.";
return;
}
bquote = madeDiv.childNodes[0];
if (bquote.tagName.toLowerCase() === "blockquote" && bquote.className.indexOf("twitter") !== -1) { //remove everything except paragraphs and links
var all = bquote.getElementsByTagName("*");
for (var i = all.length - 1; i >= 0; i--) {
var elm = all[i];
var tag = elm.tagName.toLowerCase();
if (tag !== "a" && tag !== "p")
all[i].parentNode.removeChild(all[i]);
}
} else {
thisSnippet.innerHTML = "Twitter Embed Code does not contain proper Twitter blockquote.";
return;
}
if (!window.twttr && !d.getElementById(sId)) { //async request Twitter API
var js, firstJs = d.getElementsByTagName("script")[0];
js = d.createElement("script");
js.id = sId;
js.src = "//platform.twitter.com/widgets.js";
firstJs.parentNode.insertBefore(js, firstJs);
}
thisSnippet.parentNode.style.width = "100%";
thisSnippet.appendChild(bquote);
if (window.twttr && window.twttr.widgets) {
window.twttr.widgets.load();
window.twttr.events.bind("rendered", function (e) {
//fix twitter bug rendering multiple embeds per tweet. Can be deleted after Twitter fix the issue
if (e.target) {
var par = e.target.parentElement;
if (par && par.className === "twitterSnippetProcessed" &&
e.target.previousSibling && e.target.previousSibling.nodeName.toLowerCase() === "iframe") {
//this is duplicate embed, delete it
par.removeChild(e.target);
}
}
});
}
};
thisSnippet.className = "twitterSnippetProcessed";
if (d.readyState === "uninitialized" || d.readyState === "loading")
window.addEventListener("load", render);
else //liveblog, ajax
render();
})(document);
</script>
</div>
</div>
<p>چار سال بعد ویسٹ انڈیز کے کیمار روچ نے دہلی میں کھیلے گئے ورلڈکپ میچ میں ہالینڈ کے تین بلے بازوں کو ٹھکانے لگایا لیکن اس ایڈیشن میں بھی مالنگا کا زور چلا اور وہ ورلڈکپ کرکٹ میں دو مرتبہ ہیٹ ٹرک کرنے والے کھلاڑی بن گئے۔</p>
<p>انہوں نے یہ کارنامہ کینیا کے خلاف انجام دیا جس میں ایک کھلاڑی ایل بی ڈبلیو اور باقی دونوں بولڈ تھے۔</p><div class="clear"></div>
<div class="wsw__embed">
<div class="infgraphicsAttach" >
<script type="text/javascript">
initInfographics(
{
groups:[],
params:[{"Name":"embed_html","Value":"\u0026lt;blockquote class=\"twitter-tweet\"\u0026gt;\u0026lt;p lang=\"en\" dir=\"ltr\"\u0026gt;Lasith Malinga claimed six wickets - including a hat-trick - as Sri Lanka eased to a comfortable nine-wicket victory over Kenya.\u0026lt;a href=\"https://twitter.com/hashtag/CWC11Rewind?src=hash\u0026amp;ref_src=twsrc%5Etfw\"\u0026gt;#CWC11Rewind\u0026lt;/a\u0026gt; | \u0026lt;a href=\"https://twitter.com/OfficialSLC?ref_src=twsrc%5Etfw\"\u0026gt;@OfficialSLC\u0026lt;/a\u0026gt; \u0026lt;a href=\"https://t.co/IT1SXamEak\"\u0026gt;pic.twitter.com/IT1SXamEak\u0026lt;/a\u0026gt;\u0026lt;/p\u0026gt;— ICC (@ICC) \u0026lt;a href=\"https://twitter.com/ICC/status/1366339806175846404?ref_src=twsrc%5Etfw\"\u0026gt;March 1, 2021\u0026lt;/a\u0026gt;\u0026lt;/blockquote\u0026gt;||data-pangea-embed::\"true\"","DefaultValue":"","HtmlEncode":false,"Type":"HTML"}],
isMobile:true
});
</script>
<div class="snippetLoading twitterSnippet"></div>
<script type="text/javascript">
(function (d) {
var userInput = Infographics.Param["embed_html"],
thisSnippet = (d.getElementsByClassName ? d.getElementsByClassName("twitterSnippet") : d.querySelectorAll(".twitterSnippet"))[0],
render = function () {
var madeDiv, bquote, sId = "twitterAPIForSnippet";
try {
madeDiv = document.createElement("div");
madeDiv.innerHTML = userInput;
} catch (e) {
thisSnippet.innerHTML = "Twitter Embed Code is invalid or incomplete.";
return;
}
bquote = madeDiv.childNodes[0];
if (bquote.tagName.toLowerCase() === "blockquote" && bquote.className.indexOf("twitter") !== -1) { //remove everything except paragraphs and links
var all = bquote.getElementsByTagName("*");
for (var i = all.length - 1; i >= 0; i--) {
var elm = all[i];
var tag = elm.tagName.toLowerCase();
if (tag !== "a" && tag !== "p")
all[i].parentNode.removeChild(all[i]);
}
} else {
thisSnippet.innerHTML = "Twitter Embed Code does not contain proper Twitter blockquote.";
return;
}
if (!window.twttr && !d.getElementById(sId)) { //async request Twitter API
var js, firstJs = d.getElementsByTagName("script")[0];
js = d.createElement("script");
js.id = sId;
js.src = "//platform.twitter.com/widgets.js";
firstJs.parentNode.insertBefore(js, firstJs);
}
thisSnippet.parentNode.style.width = "100%";
thisSnippet.appendChild(bquote);
if (window.twttr && window.twttr.widgets) {
window.twttr.widgets.load();
window.twttr.events.bind("rendered", function (e) {
//fix twitter bug rendering multiple embeds per tweet. Can be deleted after Twitter fix the issue
if (e.target) {
var par = e.target.parentElement;
if (par && par.className === "twitterSnippetProcessed" &&
e.target.previousSibling && e.target.previousSibling.nodeName.toLowerCase() === "iframe") {
//this is duplicate embed, delete it
par.removeChild(e.target);
}
}
});
}
};
thisSnippet.className = "twitterSnippetProcessed";
if (d.readyState === "uninitialized" || d.readyState === "loading")
window.addEventListener("load", render);
else //liveblog, ajax
render();
})(document);
</script>
</div>
</div>
<p>سن 2015 کا ورلڈکپ آسٹریلیا اور نیوزی لینڈ میں کھیلا گیا جس میں انگلینڈ کے اسٹیفن فن نے آسٹریلیا کے تین بلے بازوں کو تین گیندوں پر آؤٹ کیا۔</p>
<p>وہیں جنوبی افریقہ کے جے پی ڈومینی نے اپنی پارٹ ٹائم بالنگ سے سری لنکن بیٹسمینوں کے خلاف ہیٹ ٹرک بنائی۔</p><div class="clear"></div>
<div class="wsw__embed">
<div class="infgraphicsAttach" >
<script type="text/javascript">
initInfographics(
{
groups:[],
params:[{"Name":"embed_html","Value":"\u0026lt;blockquote class=\"twitter-tweet\"\u0026gt;\u0026lt;p lang=\"en\" dir=\"ltr\"\u0026gt;Happy birthday, Steven Finn!Although it came in a losing cause, he is one of the only 11 bowlers to have taken a hat-trick in men%27s World Cup ⬇️ \u0026lt;a href=\"https://t.co/6Ap4ftBZTY\"\u0026gt;pic.twitter.com/6Ap4ftBZTY\u0026lt;/a\u0026gt;\u0026lt;/p\u0026gt;— ICC (@ICC) \u0026lt;a href=\"https://twitter.com/ICC/status/1246402613547077632?ref_src=twsrc%5Etfw\"\u0026gt;April 4, 2020\u0026lt;/a\u0026gt;\u0026lt;/blockquote\u0026gt;||data-pangea-embed::\"true\"","DefaultValue":"","HtmlEncode":false,"Type":"HTML"}],
isMobile:true
});
</script>
<div class="snippetLoading twitterSnippet"></div>
<script type="text/javascript">
(function (d) {
var userInput = Infographics.Param["embed_html"],
thisSnippet = (d.getElementsByClassName ? d.getElementsByClassName("twitterSnippet") : d.querySelectorAll(".twitterSnippet"))[0],
render = function () {
var madeDiv, bquote, sId = "twitterAPIForSnippet";
try {
madeDiv = document.createElement("div");
madeDiv.innerHTML = userInput;
} catch (e) {
thisSnippet.innerHTML = "Twitter Embed Code is invalid or incomplete.";
return;
}
bquote = madeDiv.childNodes[0];
if (bquote.tagName.toLowerCase() === "blockquote" && bquote.className.indexOf("twitter") !== -1) { //remove everything except paragraphs and links
var all = bquote.getElementsByTagName("*");
for (var i = all.length - 1; i >= 0; i--) {
var elm = all[i];
var tag = elm.tagName.toLowerCase();
if (tag !== "a" && tag !== "p")
all[i].parentNode.removeChild(all[i]);
}
} else {
thisSnippet.innerHTML = "Twitter Embed Code does not contain proper Twitter blockquote.";
return;
}
if (!window.twttr && !d.getElementById(sId)) { //async request Twitter API
var js, firstJs = d.getElementsByTagName("script")[0];
js = d.createElement("script");
js.id = sId;
js.src = "//platform.twitter.com/widgets.js";
firstJs.parentNode.insertBefore(js, firstJs);
}
thisSnippet.parentNode.style.width = "100%";
thisSnippet.appendChild(bquote);
if (window.twttr && window.twttr.widgets) {
window.twttr.widgets.load();
window.twttr.events.bind("rendered", function (e) {
//fix twitter bug rendering multiple embeds per tweet. Can be deleted after Twitter fix the issue
if (e.target) {
var par = e.target.parentElement;
if (par && par.className === "twitterSnippetProcessed" &&
e.target.previousSibling && e.target.previousSibling.nodeName.toLowerCase() === "iframe") {
//this is duplicate embed, delete it
par.removeChild(e.target);
}
}
});
}
};
thisSnippet.className = "twitterSnippetProcessed";
if (d.readyState === "uninitialized" || d.readyState === "loading")
window.addEventListener("load", render);
else //liveblog, ajax
render();
})(document);
</script>
</div>
</div>
<p>اب تک کھیلے گئے ون ڈے کے آخری ورلڈکپ میں بھی دو ہیٹ ٹرک بنیں جن میں سے ایک بھارتی پیسر محمد شامی اور دوسری نیوزی لینڈ کےٹرینٹ بولٹ کے حصے میں آئی۔</p>
<p>محمد شامی نے تین افغان بلے بازوں کو ٹھکانے لگایا تو ٹرینٹ بولٹ نے تین آسٹریلوی بیٹسمینوں کو آؤٹ کیا۔</p><div class="clear"></div>
<div class="wsw__embed">
<div class="infgraphicsAttach" >
<script type="text/javascript">
initInfographics(
{
groups:[],
params:[{"Name":"embed_html","Value":"\u0026lt;blockquote class=\"twitter-tweet\"\u0026gt;\u0026lt;p lang=\"en\" dir=\"ltr\"\u0026gt;Two stunning grabs from Martin Guptill and Steve Smith, coupled with a hat-trick for the ages from Trent Boult. What was your \u0026lt;a href=\"https://twitter.com/Nissan?ref_src=twsrc%5Etfw\"\u0026gt;@Nissan\u0026lt;/a\u0026gt; Play of the Day? Vote here: \u0026lt;a href=\"https://t.co/7SsrSjNv2c\"\u0026gt;https://t.co/7SsrSjNv2c\u0026lt;/a\u0026gt;\u0026lt;a href=\"https://twitter.com/hashtag/NZvAUS?src=hash\u0026amp;ref_src=twsrc%5Etfw\"\u0026gt;#NZvAUS\u0026lt;/a\u0026gt; | \u0026lt;a href=\"https://twitter.com/hashtag/BackTheBlackCaps?src=hash\u0026amp;ref_src=twsrc%5Etfw\"\u0026gt;#BackTheBlackCaps\u0026lt;/a\u0026gt; | \u0026lt;a href=\"https://twitter.com/hashtag/CmonAussie?src=hash\u0026amp;ref_src=twsrc%5Etfw\"\u0026gt;#CmonAussie\u0026lt;/a\u0026gt; | \u0026lt;a href=\"https://twitter.com/hashtag/CWC19?src=hash\u0026amp;ref_src=twsrc%5Etfw\"\u0026gt;#CWC19\u0026lt;/a\u0026gt; \u0026lt;a href=\"https://t.co/kWV9sET7gA\"\u0026gt;pic.twitter.com/kWV9sET7gA\u0026lt;/a\u0026gt;\u0026lt;/p\u0026gt;— ICC (@ICC) \u0026lt;a href=\"https://twitter.com/ICC/status/1145089549355442177?ref_src=twsrc%5Etfw\"\u0026gt;June 29, 2019\u0026lt;/a\u0026gt;\u0026lt;/blockquote\u0026gt;||data-pangea-embed::\"true\"","DefaultValue":"","HtmlEncode":false,"Type":"HTML"}],
isMobile:true
});
</script>
<div class="snippetLoading twitterSnippet"></div>
<script type="text/javascript">
(function (d) {
var userInput = Infographics.Param["embed_html"],
thisSnippet = (d.getElementsByClassName ? d.getElementsByClassName("twitterSnippet") : d.querySelectorAll(".twitterSnippet"))[0],
render = function () {
var madeDiv, bquote, sId = "twitterAPIForSnippet";
try {
madeDiv = document.createElement("div");
madeDiv.innerHTML = userInput;
} catch (e) {
thisSnippet.innerHTML = "Twitter Embed Code is invalid or incomplete.";
return;
}
bquote = madeDiv.childNodes[0];
if (bquote.tagName.toLowerCase() === "blockquote" && bquote.className.indexOf("twitter") !== -1) { //remove everything except paragraphs and links
var all = bquote.getElementsByTagName("*");
for (var i = all.length - 1; i >= 0; i--) {
var elm = all[i];
var tag = elm.tagName.toLowerCase();
if (tag !== "a" && tag !== "p")
all[i].parentNode.removeChild(all[i]);
}
} else {
thisSnippet.innerHTML = "Twitter Embed Code does not contain proper Twitter blockquote.";
return;
}
if (!window.twttr && !d.getElementById(sId)) { //async request Twitter API
var js, firstJs = d.getElementsByTagName("script")[0];
js = d.createElement("script");
js.id = sId;
js.src = "//platform.twitter.com/widgets.js";
firstJs.parentNode.insertBefore(js, firstJs);
}
thisSnippet.parentNode.style.width = "100%";
thisSnippet.appendChild(bquote);
if (window.twttr && window.twttr.widgets) {
window.twttr.widgets.load();
window.twttr.events.bind("rendered", function (e) {
//fix twitter bug rendering multiple embeds per tweet. Can be deleted after Twitter fix the issue
if (e.target) {
var par = e.target.parentElement;
if (par && par.className === "twitterSnippetProcessed" &&
e.target.previousSibling && e.target.previousSibling.nodeName.toLowerCase() === "iframe") {
//this is duplicate embed, delete it
par.removeChild(e.target);
}
}
});
}
};
thisSnippet.className = "twitterSnippetProcessed";
if (d.readyState === "uninitialized" || d.readyState === "loading")
window.addEventListener("load", render);
else //liveblog, ajax
render();
})(document);
</script>
</div>
</div>
<p> </p>
</div>
<ul>
</ul>
<div id="comments" class="comments-parent">
<div class="row">
<div class="col-xs-12">
<div class="comments comments--fb">
<h3 class="section-head">فیس بک فورم</h3>
<div class="comments-form comments-facebook">
<div class="fb-comments" data-href="https://www.urduvoa.com/a/hasaranga-becomes-3rd-bowler-to-pick-a-hattrick-in-t20wc-30oct2021/6292086.html" data-numposts="2" data-mobile="true"></div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="col-xs-12 col-sm-12 col-md-4 col-lg-4 pull-left design-top-offset"> <div class="media-block-wrap">
<h2 class="section-head">متعلقہ</h2>
<div class="row">
<ul>
<li class="col-xs-12 col-sm-6 col-md-12 col-lg-12 mb-grid">
<div class="media-block ">
<a href="/a/record-of-pakistani-players-against-afghanistan-30oct2021/6291928.html" class="img-wrap img-wrap--t-spac img-wrap--size-4 img-wrap--float" title="افغانستان کے خلاف میچ میں کئی اہم ریکارڈز پاکستانی کھلاڑیوں نے اپنے نام کیے">
<div class="thumb thumb16_9">
<noscript class="nojs-img">
<img src="https://gdb.voanews.com/7137480C-557B-4DF2-8D7F-055F37E6B764_w100_r1.jpg" alt="افغانستان کے خلاف میچ میں کئی اہم ریکارڈز پاکستانی کھلاڑیوں نے اپنے نام کیے" />
</noscript>
<img data-src="https://gdb.voanews.com/7137480C-557B-4DF2-8D7F-055F37E6B764_w33_r1.jpg" src="" alt="افغانستان کے خلاف میچ میں کئی اہم ریکارڈز پاکستانی کھلاڑیوں نے اپنے نام کیے" />
</div>
</a>
<div class="media-block__content media-block__content--h">
<a href="/a/record-of-pakistani-players-against-afghanistan-30oct2021/6291928.html" rel="noopener">
<h4 class="media-block__title media-block__title--size-4" title="افغانستان کے خلاف میچ میں کئی اہم ریکارڈز پاکستانی کھلاڑیوں نے اپنے نام کیے">
افغانستان کے خلاف میچ میں کئی اہم ریکارڈز پاکستانی کھلاڑیوں نے اپنے نام کیے
</h4>
</a>
</div>
</div>
</li>
<li class="col-xs-12 col-sm-6 col-md-12 col-lg-12 mb-grid">
<div class="media-block ">
<a href="/a/asif-ali-smashes-four-sixes-as-pakistan-wins-thriller-against-afghanistan-in-t20-worldcup-29oct2021/6291258.html" class="img-wrap img-wrap--t-spac img-wrap--size-4 img-wrap--float" title="آصف علی; &#39;نام یاد رکھنا&#39;">
<div class="thumb thumb16_9">
<noscript class="nojs-img">
<img src="https://gdb.voanews.com/77347114-3D6A-498A-AEA2-B4CC132C7220_cx0_cy10_cw0_w100_r1.jpg" alt="آصف علی; &#39;نام یاد رکھنا&#39;" />
</noscript>
<img data-src="https://gdb.voanews.com/77347114-3D6A-498A-AEA2-B4CC132C7220_cx0_cy10_cw0_w33_r1.jpg" src="" alt="آصف علی; &#39;نام یاد رکھنا&#39;" />
</div>
</a>
<div class="media-block__content media-block__content--h">
<a href="/a/asif-ali-smashes-four-sixes-as-pakistan-wins-thriller-against-afghanistan-in-t20-worldcup-29oct2021/6291258.html" rel="noopener">
<h4 class="media-block__title media-block__title--size-4" title="آصف علی; &#39;نام یاد رکھنا&#39;">
آصف علی; &#39;نام یاد رکھنا&#39;
</h4>
</a>
</div>
</div>
</li>
<li class="col-xs-12 col-sm-6 col-md-12 col-lg-12 mb-grid">
<div class="media-block ">
<a href="/a/pakistan-vs-afghanistan-t20-world-cup-29oct2021/6290822.html" class="img-wrap img-wrap--t-spac img-wrap--size-4 img-wrap--float" title="آصف علی کی شان دار بیٹنگ، پاکستان نے افغانستان کو پانچ وکٹوں سے شکست دے دی">
<div class="thumb thumb16_9">
<noscript class="nojs-img">
<img src="https://gdb.voanews.com/4B3430EB-EA39-46FD-A632-28501E8E3C50_w100_r1.jpg" alt="آصف علی کی شان دار بیٹنگ، پاکستان نے افغانستان کو پانچ وکٹوں سے شکست دے دی" />
</noscript>
<img data-src="https://gdb.voanews.com/4B3430EB-EA39-46FD-A632-28501E8E3C50_w33_r1.jpg" src="" alt="آصف علی کی شان دار بیٹنگ، پاکستان نے افغانستان کو پانچ وکٹوں سے شکست دے دی" />
</div>
</a>
<div class="media-block__content media-block__content--h">
<a href="/a/pakistan-vs-afghanistan-t20-world-cup-29oct2021/6290822.html" rel="noopener">
<h4 class="media-block__title media-block__title--size-4" title="آصف علی کی شان دار بیٹنگ، پاکستان نے افغانستان کو پانچ وکٹوں سے شکست دے دی">
آصف علی کی شان دار بیٹنگ، پاکستان نے افغانستان کو پانچ وکٹوں سے شکست دے دی
</h4>
</a>
</div>
</div>
</li>
<li class="col-xs-12 col-sm-6 col-md-12 col-lg-12 mb-grid">
<div class="media-block ">
<a href="/a/twelve-players-in-super-twelve-t20worldcup-28oct2021/6284154.html" class="img-wrap img-wrap--t-spac img-wrap--size-4 img-wrap--float" title="ٹی ٹوئنٹی ورلڈ کپ: سپر 12 مرحلے کے 12 اہم ترین کھلاڑی کون؟">
<div class="thumb thumb16_9">
<noscript class="nojs-img">
<img src="https://gdb.voanews.com/D772739A-B93A-44EC-B787-22184D5D41D9_w100_r1.png" alt="ٹی ٹوئنٹی ورلڈ کپ: سپر 12 مرحلے کے 12 اہم ترین کھلاڑی کون؟" />
</noscript>
<img data-src="https://gdb.voanews.com/D772739A-B93A-44EC-B787-22184D5D41D9_w33_r1.png" src="" alt="ٹی ٹوئنٹی ورلڈ کپ: سپر 12 مرحلے کے 12 اہم ترین کھلاڑی کون؟" />
</div>
</a>
<div class="media-block__content media-block__content--h">
<a href="/a/twelve-players-in-super-twelve-t20worldcup-28oct2021/6284154.html" rel="noopener">
<h4 class="media-block__title media-block__title--size-4" title="ٹی ٹوئنٹی ورلڈ کپ: سپر 12 مرحلے کے 12 اہم ترین کھلاڑی کون؟">
ٹی ٹوئنٹی ورلڈ کپ: سپر 12 مرحلے کے 12 اہم ترین کھلاڑی کون؟
</h4>
</a>
</div>
</div>
</li>
<li class="col-xs-12 col-sm-6 col-md-12 col-lg-12 mb-grid">
<div class="media-block ">
<a href="/a/asif-ali-memes-come-true/6287900.html" class="img-wrap img-wrap--t-spac img-wrap--size-4 img-wrap--float" title="آصف علی؛ &#39;میمز کم ٹرو&#39;">
<div class="thumb thumb16_9">
<noscript class="nojs-img">
<img src="https://gdb.voanews.com/34828263-D298-4224-AE1C-02DD43293C45_cx22_cy11_cw62_w100_r1.jpg" alt="آصف علی؛ &#39;میمز کم ٹرو&#39;" />
</noscript>
<img data-src="https://gdb.voanews.com/34828263-D298-4224-AE1C-02DD43293C45_cx22_cy11_cw62_w33_r1.jpg" src="" alt="آصف علی؛ &#39;میمز کم ٹرو&#39;" />
</div>
</a>
<div class="media-block__content media-block__content--h">
<a href="/a/asif-ali-memes-come-true/6287900.html" rel="noopener">
<h4 class="media-block__title media-block__title--size-4" title="آصف علی؛ &#39;میمز کم ٹرو&#39;">
آصف علی؛ &#39;میمز کم ٹرو&#39;
</h4>
</a>
</div>
</div>
</li>
<li class="col-xs-12 col-sm-6 col-md-12 col-lg-12 mb-grid">
<div class="media-block ">
<a href="/a/pakistan-choose-to-field-first-with-newzealand-26oct2021/6286022.html" class="img-wrap img-wrap--t-spac img-wrap--size-4 img-wrap--float" title="ٹی 20 ورلڈ کپ میں پاکستان کی دوسری کامیابی، نیوزی لینڈ کو پانچ وکٹوں سے شکست">
<div class="thumb thumb16_9">
<noscript class="nojs-img">
<img src="https://gdb.voanews.com/D1294472-3937-40CC-B17A-37DA3FDAE817_w100_r1.jpg" alt="ٹی 20 ورلڈ کپ میں پاکستان کی دوسری کامیابی، نیوزی لینڈ کو پانچ وکٹوں سے شکست" />
</noscript>
<img data-src="https://gdb.voanews.com/D1294472-3937-40CC-B17A-37DA3FDAE817_w33_r1.jpg" src="" alt="ٹی 20 ورلڈ کپ میں پاکستان کی دوسری کامیابی، نیوزی لینڈ کو پانچ وکٹوں سے شکست" />
</div>
</a>
<div class="media-block__content media-block__content--h">
<a href="/a/pakistan-choose-to-field-first-with-newzealand-26oct2021/6286022.html" rel="noopener">
<h4 class="media-block__title media-block__title--size-4" title="ٹی 20 ورلڈ کپ میں پاکستان کی دوسری کامیابی، نیوزی لینڈ کو پانچ وکٹوں سے شکست">
ٹی 20 ورلڈ کپ میں پاکستان کی دوسری کامیابی، نیوزی لینڈ کو پانچ وکٹوں سے شکست
</h4>
</a>
</div>
</div>
</li>
<li class="col-xs-12 col-sm-6 col-md-12 col-lg-12 mb-grid">
<div class="media-block ">
<a href="/a/fir-against-students-for-raising-pro-pakistan-slogans-in-kashmir-26oct2021/6285886.html" class="img-wrap img-wrap--t-spac img-wrap--size-4 img-wrap--float" title="بھارتی کشمیر: ٹی ٹوئنٹی ورلڈکپ میں پاکستان کی کامیابی&#160;پر جشن منانے والے طلبہ پر مقدمات درج">
<div class="thumb thumb16_9">
<noscript class="nojs-img">
<img src="https://gdb.voanews.com/FE2180C0-5CA9-496E-A874-D096550BB32C_w100_r1.png" alt="بھارتی کشمیر: ٹی ٹوئنٹی ورلڈکپ میں پاکستان کی کامیابی&#160;پر جشن منانے والے طلبہ پر مقدمات درج" />
</noscript>
<img data-src="https://gdb.voanews.com/FE2180C0-5CA9-496E-A874-D096550BB32C_w33_r1.png" src="" alt="بھارتی کشمیر: ٹی ٹوئنٹی ورلڈکپ میں پاکستان کی کامیابی&#160;پر جشن منانے والے طلبہ پر مقدمات درج" />
</div>
</a>
<div class="media-block__content media-block__content--h">
<a href="/a/fir-against-students-for-raising-pro-pakistan-slogans-in-kashmir-26oct2021/6285886.html" rel="noopener">
<h4 class="media-block__title media-block__title--size-4" title="بھارتی کشمیر: ٹی ٹوئنٹی ورلڈکپ میں پاکستان کی کامیابی&#160;پر جشن منانے والے طلبہ پر مقدمات درج">
بھارتی کشمیر: ٹی ٹوئنٹی ورلڈکپ میں پاکستان کی کامیابی&#160;پر جشن منانے والے طلبہ پر مقدمات درج
</h4>
</a>
</div>
</div>
</li>
<li class="col-xs-12 col-sm-6 col-md-12 col-lg-12 mb-grid">
<div class="media-block ">
<a href="/a/pakistan-india-cricket-match-a-clash-of-memes/6285132.html" class="img-wrap img-wrap--t-spac img-wrap--size-4 img-wrap--float" title="پاکستان بھارت میچ: ایک طرف ٹیمز، دوسری طرف میمز کی ’جنگ‘">
<div class="thumb thumb16_9">
<noscript class="nojs-img">
<img src="https://gdb.voanews.com/92E1FDCB-35BD-4799-95EC-EBEE7E2F7A9F_cx8_cy0_cw70_w100_r1.jpg" alt="پاکستان بھارت میچ: ایک طرف ٹیمز، دوسری طرف میمز کی ’جنگ‘" />
</noscript>
<img data-src="https://gdb.voanews.com/92E1FDCB-35BD-4799-95EC-EBEE7E2F7A9F_cx8_cy0_cw70_w33_r1.jpg" src="" alt="پاکستان بھارت میچ: ایک طرف ٹیمز، دوسری طرف میمز کی ’جنگ‘" />
</div>
</a>
<div class="media-block__content media-block__content--h">
<a href="/a/pakistan-india-cricket-match-a-clash-of-memes/6285132.html" rel="noopener">
<h4 class="media-block__title media-block__title--size-4" title="پاکستان بھارت میچ: ایک طرف ٹیمز، دوسری طرف میمز کی ’جنگ‘">
پاکستان بھارت میچ: ایک طرف ٹیمز، دوسری طرف میمز کی ’جنگ‘
</h4>
</a>
</div>
</div>
</li>
<li class="col-xs-12 col-sm-6 col-md-12 col-lg-12 mb-grid">
<div class="media-block ">
<a href="/a/social-media-reacts-over-pakistan-vs-india-match-25oct2021/6284204.html" class="img-wrap img-wrap--t-spac img-wrap--size-4 img-wrap--float" title="پاکستان سے شکست پر بھارتی شائقینِ کرکٹ مایوس، کئی علاقوں میں آتش بازی پر سابق کرکٹر برہم">
<div class="thumb thumb16_9">
<noscript class="nojs-img">
<img src="https://gdb.voanews.com/0C35E148-A4D0-4364-BECB-23E6B5379745_cx0_cy10_cw0_w100_r1.jpg" alt="پاکستان سے شکست پر بھارتی شائقینِ کرکٹ مایوس، کئی علاقوں میں آتش بازی پر سابق کرکٹر برہم" />
</noscript>
<img data-src="https://gdb.voanews.com/0C35E148-A4D0-4364-BECB-23E6B5379745_cx0_cy10_cw0_w33_r1.jpg" src="" alt="پاکستان سے شکست پر بھارتی شائقینِ کرکٹ مایوس، کئی علاقوں میں آتش بازی پر سابق کرکٹر برہم" />
</div>
</a>
<div class="media-block__content media-block__content--h">
<a href="/a/social-media-reacts-over-pakistan-vs-india-match-25oct2021/6284204.html" rel="noopener">
<h4 class="media-block__title media-block__title--size-4" title="پاکستان سے شکست پر بھارتی شائقینِ کرکٹ مایوس، کئی علاقوں میں آتش بازی پر سابق کرکٹر برہم">
پاکستان سے شکست پر بھارتی شائقینِ کرکٹ مایوس، کئی علاقوں میں آتش بازی پر سابق کرکٹر برہم
</h4>
</a>
</div>
</div>
</li>
<li class="col-xs-12 col-sm-6 col-md-12 col-lg-12 mb-grid">
<div class="media-block ">
<a href="/a/pakistan-win-by-10-wickets-to-register-first-world-cup-victory-against-india-24oct2021/6282770.html" class="img-wrap img-wrap--t-spac img-wrap--size-4 img-wrap--float" title="ٹی ٹوئںٹی ورلڈکپ: پاکستان نے بھارت کو 10 وکٹوں سے شکست دے کر تاریخ رقم کر دی">
<div class="thumb thumb16_9">
<noscript class="nojs-img">
<img src="https://gdb.voanews.com/6A170FC6-4D92-4332-B00F-150EDA3A5272_w100_r1.jpg" alt="ٹی ٹوئںٹی ورلڈکپ: پاکستان نے بھارت کو 10 وکٹوں سے شکست دے کر تاریخ رقم کر دی" />
</noscript>
<img data-src="https://gdb.voanews.com/6A170FC6-4D92-4332-B00F-150EDA3A5272_w33_r1.jpg" src="" alt="ٹی ٹوئںٹی ورلڈکپ: پاکستان نے بھارت کو 10 وکٹوں سے شکست دے کر تاریخ رقم کر دی" />
</div>
</a>
<div class="media-block__content media-block__content--h">
<a href="/a/pakistan-win-by-10-wickets-to-register-first-world-cup-victory-against-india-24oct2021/6282770.html" rel="noopener">
<h4 class="media-block__title media-block__title--size-4" title="ٹی ٹوئںٹی ورلڈکپ: پاکستان نے بھارت کو 10 وکٹوں سے شکست دے کر تاریخ رقم کر دی">
ٹی ٹوئںٹی ورلڈکپ: پاکستان نے بھارت کو 10 وکٹوں سے شکست دے کر تاریخ رقم کر دی
</h4>
</a>
</div>
</div>
</li>
<li class="col-xs-12 col-sm-6 col-md-12 col-lg-12 mb-grid">
<div class="media-block ">
<a href="/a/why-pakistan-still-waiting-for-first-win-against-india-in-world-cup-24oct2021/6281239.html" class="img-wrap img-wrap--t-spac img-wrap--size-4 img-wrap--float" title="ورلڈ کپ میں بھارت کا پاکستان کے خلاف بہتر ریکارڈ، &#39;پاکستانی ٹیم دباؤ میں آ جاتی ہے&#39;">
<div class="thumb thumb16_9">
<noscript class="nojs-img">
<img src="https://gdb.voanews.com/837D8BA4-B34B-4972-8F58-E9F816E5CD9B_w100_r1.jpg" alt="ورلڈ کپ میں بھارت کا پاکستان کے خلاف بہتر ریکارڈ، &#39;پاکستانی ٹیم دباؤ میں آ جاتی ہے&#39;" />
</noscript>
<img data-src="https://gdb.voanews.com/837D8BA4-B34B-4972-8F58-E9F816E5CD9B_w33_r1.jpg" src="" alt="ورلڈ کپ میں بھارت کا پاکستان کے خلاف بہتر ریکارڈ، &#39;پاکستانی ٹیم دباؤ میں آ جاتی ہے&#39;" />
</div>
</a>
<div class="media-block__content media-block__content--h">
<a href="/a/why-pakistan-still-waiting-for-first-win-against-india-in-world-cup-24oct2021/6281239.html" rel="noopener">
<h4 class="media-block__title media-block__title--size-4" title="ورلڈ کپ میں بھارت کا پاکستان کے خلاف بہتر ریکارڈ، &#39;پاکستانی ٹیم دباؤ میں آ جاتی ہے&#39;">
ورلڈ کپ میں بھارت کا پاکستان کے خلاف بہتر ریکارڈ، &#39;پاکستانی ٹیم دباؤ میں آ جاتی ہے&#39;
</h4>
</a>
</div>
</div>
</li>
<li class="col-xs-12 col-sm-6 col-md-12 col-lg-12 mb-grid">
<div class="media-block ">
<a href="/a/amazing-matches-between-pakistan-and-india-23oct2021/6281177.html" class="img-wrap img-wrap--t-spac img-wrap--size-4 img-wrap--float" title="پاکستان اور بھارت کی کرکٹ ٹیموں کے وہ پانچ ٹاکرے جو ہمیشہ یادگار رہیں گے">
<div class="thumb thumb16_9">
<noscript class="nojs-img">
<img src="https://gdb.voanews.com/8B12E6B5-6263-4C63-8D03-B93BC7F5190F_w100_r1.jpg" alt="پاکستان اور بھارت کی کرکٹ ٹیموں کے وہ پانچ ٹاکرے جو ہمیشہ یادگار رہیں گے" />
</noscript>
<img data-src="https://gdb.voanews.com/8B12E6B5-6263-4C63-8D03-B93BC7F5190F_w33_r1.jpg" src="" alt="پاکستان اور بھارت کی کرکٹ ٹیموں کے وہ پانچ ٹاکرے جو ہمیشہ یادگار رہیں گے" />
</div>
</a>
<div class="media-block__content media-block__content--h">
<a href="/a/amazing-matches-between-pakistan-and-india-23oct2021/6281177.html" rel="noopener">
<h4 class="media-block__title media-block__title--size-4" title="پاکستان اور بھارت کی کرکٹ ٹیموں کے وہ پانچ ٹاکرے جو ہمیشہ یادگار رہیں گے">
پاکستان اور بھارت کی کرکٹ ٹیموں کے وہ پانچ ٹاکرے جو ہمیشہ یادگار رہیں گے
</h4>
</a>
</div>
</div>
</li>
</ul>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="back-to-top-nav disabled visible-xs">
<div class="container">
<div class="row">
<div class="col-xs-12">
<a title="Back to top" class="back-to-top-link" href="#page">
<span class="ico ico-chevron-up"></span>
<span class="text">Back to top</span>
</a>
</div>
</div>
</div>
</div>
<footer role="contentinfo">
<div id="foot" class="foot">
<div class="container">
<div class="foot-nav collapsed" id="foot-nav">
<div class="menu">
<ul class="items">
<li class="socials block-socials">
<span class="handler" id="socials-handler">
Follow Us
</span>
<div class="inner">
<ul class="subitems follow">
<li>
<a href="https://facebook.com/voaurdu" title="ہم فیس بک پر موجود ہیں" data-analytics-text="follow_on_facebook" class="btn btn--rounded js-social-btn btn-facebook" target="_blank">
<span class="ico ico-facebook-alt ico--rounded"></span>
</a>
</li>
<li>
<a href="https://twitter.com/urduvoa" title="ہم ٹوئٹر پر موجود ہیں" data-analytics-text="follow_on_twitter" class="btn btn--rounded js-social-btn btn-twitter" target="_blank">
<span class="ico ico-twitter ico--rounded"></span>
</a>
</li>
<li>
<a href="https://www.youtube.com/c/urduvoaservice" title="ہم یوٹیوب پر موجود ہیں" data-analytics-text="follow_on_youtube" class="btn btn--rounded js-social-btn btn-youtube" target="_blank">
<span class="ico ico-youtube ico--rounded"></span>
</a>
</li>
<li>
<a href="https://www.instagram.com/urduvoa/" title="Follow us on Instagram" data-analytics-text="follow_on_instagram" class="btn btn--rounded js-social-btn btn-instagram" target="_blank">
<span class="ico ico-instagram ico--rounded"></span>
</a>
</li>
<li>
<a href="/rssfeeds" title="RSS" data-analytics-text="follow_on_rss" class="btn btn--rounded js-social-btn btn-rss" >
<span class="ico ico-rss ico--rounded"></span>
</a>
</li>
<li>
<a href="/podcasts" title="Podcast" data-analytics-text="follow_on_podcast" class="btn btn--rounded js-social-btn btn-podcast" >
<span class="ico ico-podcast ico--rounded"></span>
</a>
</li>
<li>
<a href="/subscribe.html" title="Subscribe" data-analytics-text="follow_on_subscribe" class="btn btn--rounded js-social-btn btn-email" >
<span class="ico ico-email ico--rounded"></span>
</a>
</li>
</ul>
</div>
</li>
<li class="block-primary collapsed collapsible item">
<span class="handler">
ہمارے بارے میں
<span title="close tab" class="ico ico-chevron-up"></span>
<span title="open tab" class="ico ico-chevron-down"></span>
<span title="add" class="ico ico-plus"></span>
<span title="remove" class="ico ico-minus"></span>
</span>
<div class="inner">
<ul class="subitems">
<li class="subitem">
<a class="handler" href="/p/3808.html" title="ہم سے رابطہ کیجیئے">ہم سے رابطہ کیجیئے</a>
</li>
<li class="subitem">
<a class="handler" href="/p/3811.html" title="ہمارے بارے میں">ہمارے بارے میں</a>
</li>
<li class="subitem">
<a class="handler" href="/p/7289.html" title="رسائی کا طریقہ کار">رسائی کا طریقہ کار</a>
</li>
<li class="subitem">
<a class="handler" href="/p/7823.html" title="پرائیویسی نوٹس">پرائیویسی نوٹس</a>
</li>
</ul>
</div>
</li>
<li class="block-primary collapsed collapsible item">
<span class="handler">
Links
<span title="close tab" class="ico ico-chevron-up"></span>
<span title="open tab" class="ico ico-chevron-down"></span>
<span title="add" class="ico ico-plus"></span>
<span title="remove" class="ico ico-minus"></span>
</span>
<div class="inner">
<ul class="subitems">
<li class="subitem">
<a class="handler" href="http://www.voanews.com/" title="VOA English">VOA English</a>
</li>
<li class="subitem">
<a class="handler" href="http://www.darivoa.com/" title="VOA Dari">VOA Dari</a>
</li>
<li class="subitem">
<a class="handler" href="http://www.pashtovoa.com/" title="VOA Pashto">VOA Pashto</a>
</li>
<li class="subitem">
<a class="handler" href="http://www.voadeewaradio.com/" title="VOA Deewa">VOA Deewa</a>
</li>
</ul>
</div>
</li>
</ul>
</div>
</div>
<div class="foot__item foot__item--copyrights">
<p class="copyright"></p>
</div>
</div>
</div>
</footer> </div>
</div>
<script type="text/javascript">
// register service worker if supported
// Service-worker file needs to exist in root folder, because it defines its scope = it can intercept only requests below it in the tree structure
var isPreview = (/[\&\?](previewId|design)=/).test(window.location.href);
if (!isPreview) {
window.addEventListener('load', function () {
if ('serviceWorker' in navigator && (pwaEnabled || typeof OneSignal != 'undefined' || !swCacheDisabled)) {
var sw = '/OneSignalSDKWorker.js';
if (typeof OneSignal != 'undefined' && OneSignal.config) {
sw = sw + '?appId=' + OneSignal.config.appId;
}
if (pwaEnabled) {
sw = sw.indexOf('?') > -1 ? sw + '&pwa=true' : sw + '?pwa=true';
}
if (swCacheDisabled) {
sw = sw.indexOf('?') > -1 ? sw + '&sw-cache-dis=true' : sw + '?sw-cache-dis=true';
}
navigator.serviceWorker.register(sw).then(function (registration) {
console.log('ServiceWorker registration successful with scope: ', registration.scope);
}, function (err) {
console.log('ServiceWorker registration failed: ', err);
});
}
});
}
</script>
<script type="text/javascript">
// opera mini - disable ico font
if (navigator.userAgent.match(/Opera Mini/i)) {
document.getElementsByTagName("body")[0].className.replace("can-ff", "");
}
// mobile browsers test
if (typeof RFE !== 'undefined') {
if (RFE.isMobile.any()) {
document.getElementsByTagName("body")[0].className += " is-mobile";
}
else {
document.getElementsByTagName("body")[0].className += " is-not-mobile";
}
}
</script>
<script src="/conf.js?x=161" type="text/javascript"></script>
<div class="responsive-indicator">
<div class="visible-xs-block">XS</div>
<div class="visible-sm-block">SM</div>
<div class="visible-md-block">MD</div>
<div class="visible-lg-block">LG</div>
</div>
<script type="text/javascript">
var bar_data = {
"apiId": "6292086",
"apiType": "1",
"isEmbedded": "0",
"culture": "ur",
"cookieName": "cmsLoggedIn",
"cookieDomain": "www.urduvoa.com"
};
</script>
<div id="scriptLoaderTarget" style="display:none;contain:strict;"></div>
</body>
</html>